I upgraded my Ubuntu to Raring Ringtail.

After that, when starting QGIS I receive a message:

Couldn't load PyQGIS.
Python support will be disabled.

Traceback (most recent call last):
  File "", line 1, in 
RuntimeError: the sip module implements API v9.0 to v9.2 but the qgis.core module requires API v8.1  

Python version:
2.7.4 (default, Apr 19 2013, 18:30:41) 
[GCC 4.7.3]

QGIS version:
1.7.5-Wroclaw 'Wroclaw', exported

Python path:
['/usr/share/qgis/python', '/home/rdk/.qgis/python', '/home/rdk/.qgis/python/plugins', '/usr/share/qgis/python/plugins', '/usr/local/lib/python2.7/dist-packages/pyspatialite-2.6.1-py2.7-linux-x86_64.egg', '/usr/lib/pymodules/python2.7', '/usr/local/lib/python2.7/dist-packages/networkx-1.5-py2.7.egg', '/usr/local/lib/python2.7/dist-packages/psycopg2-2.4.2-py2.7-linux-x86_64.egg', '/usr/local/lib/python2.7/dist-packages/twittercollect-0.1.0-py2.7.egg', '/usr/local/lib/python2.7/dist-packages/pip-1.1-py2.7.egg', '/usr/local/lib/python2.7/dist-packages/Shapely-1.2.14-py2.7.egg', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gst-0.10', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/python2.7/dist-packages/ubuntu-sso-client', '/usr/lib/python2.7/dist-packages/ubuntuone-client', '/usr/lib/python2.7/dist-packages/ubuntuone-control-panel', '/usr/lib/python2.7/dist-packages/ubuntuone-couch', '/usr/lib/python2.7/dist-packages/ubuntuone-storage-protocol', '/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode']

What is causing such problem? How could I fix it?

  • Which repos do you use? – underdark May 5 '13 at 17:05
  • 1
    @underdark ppa:ubuntugis/ubuntugis-unstable for the moment. But I cannot see qgis there for Raring.. Could that be causing installation of 1.7? – radek May 5 '13 at 17:31

Upgrade to QGIS 1.8: http://hub.qgis.org/projects/quantum-gis/wiki/Download#26-Ubuntu

The problem is your sip is too new to work with the older 1.7 release.

  • I tried follow the instruction but when I run sudo apt-get install qgis the qgis version that install is the 1.7.5 :( – Overflow012 Nov 24 '13 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.