ArcMap wont display the attribute table of a dataset.

I get an error 'Could not load data from the data source' and it says 'An invalid SQL statement was used'. It then opens a table with the correct number of fields, but no field headers and no data.

It does however display the attribute table if I make a selection and ask it to show only the selection, and I can select every record in the table and it works.

It also displays the values if I use the identify button.

The datasource is a table in a Geodatabase and was created from FME. FME reports no errors in loading the data, and loads all of the records it is given. Using ArcGIS 10.1 SP1.

The table has no special characters in the table name, or the field names.

Edit 10/05/2013

The Geodatabase will open in QGIS. If I export to another features class in a file geodatabase using ArcCatalog it the works. I have tried using the FILEGDB and GEODATABASE_FILE writers in FME and the attribute table will not open in ArcMap. Both work in QGIS 1.8

  • Do you have any very long text fields in the table?
    – PolyGeo
    May 8, 2013 at 7:20
  • The longest text field is no more than 200 characters. I have just tried opening the geodatabase table in QGIS and it opened without issue.
    – James S
    May 8, 2013 at 10:19
  • 1
    Are you able to export the table from the TOC or Catalog window into a new one of the same format to see whether it "loses" whatever it thinks is wrong with it?
    – PolyGeo
    May 8, 2013 at 10:57
  • It works once I export to another feature class in the same geodatabase. So what is the problem? Arc or FME?
    – James S
    May 8, 2013 at 11:26
  • 1
    In this case I would lean towards FME because it is they who are creating the data. However, if they are using the Open File Geodatabase API correctly then it may point back at Esri. I would recommend submitting the problem to support from both vendors who should then talk to each other and resolve where the problem lies.
    – PolyGeo
    May 8, 2013 at 12:09

1 Answer 1


Thanks for sending that to Safe Software support James. This helped us see the issue which was a field name 'Order" which is a reserved word for file geodatabase. FME generally will catch these and I have followed up with problem report. The solution is to change that field name in the destination feature type in FME Workbench.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.