4

I installed Geoexplorer 3.0.2 according to instructions. I also setup GEOEXPLORER_DATA in web.xml file and it seems that it works fine because http://localhost:8080/geoexplorer/maps/? returns:

{"maps":[]}

But when I'm trying to Save my map I get back the half link:

http://localhost:8080/geoexplorer/composer/

Notice there is no #maps/MapID at the end of the above link,as it was supposed to be.

Also when I'm trying to Publish my map I get the following link:

<iframe style="border: none;" height="400" width="600" src="http://localhost:8080/geoexplorer/viewer/#maps/undefined"></iframe>

Notice that instead of MapID at the end of the above link, it gives me the undefined

The directory GEOEXPLORER_DATA and geoexplorer.db have full permissions to tomcat7 user/group. Is it an insertion problem in my db file? Is it a bug or something else?

If I run GeoExplorer in development mode (without setting any GEOEXPLORER_DATA directory), I have no problem. I can Save and Publish my maps. I only have that problem when I run it under deployment in a production environment (under tomcat7).

Maybe is a GeoServer Proxy problem because during debugging I get:

POST http://myexternal_IP:8080/geoexplorer/maps/ 401 (Unauthorized) GeoExplorer.js:396
    b.send GeoExplorer.js:396
    (anonymous function)
Trouble saving: {"error":"Not authorized"} 

My configuration is the following:

I set up Proxy Base URL of Geoserver to http://myexternal_IP/geoserver
I also setup Apache ProxyPass:

ProxyRequests Off
ProxyPreserveHost On
<Proxy *>
Order deny,allow
Allow from all
</Proxy>
ProxyPass /geoserver http://localhost:8080/geoserver
ProxyPassReverse /geoserver http://localhost:8080/geoserver

Finally, I build the app with:

ant -Dapp.proxy.geoserver=http://myexternal_IP/geoserver debug

But the problem still remains...

  • Which web browser are you using? – Mapperz May 8 '13 at 20:00
  • Firefox 19.0 and Google Chrome 21.0.1180.89 – Leonidas Liakos May 8 '13 at 20:22
1

As Leonidas, I encountered absolutely identical problems.

After searching a lot of info in GeoExplorer/GeoServer/Tomcat/Java forums, I thought the problem might be related to... GeoServer!

So, after the deployement of the latest geoserver.war, I was surprised to see that everything works OK!!!

Now I am able to save and export any kind of maps!

I think there are some incompatibilities between different geoserver and geoexplorer releases.

0

Make sure that the tomcat user has write access to your geoexplorer.db file. If this does not help, use your browser's development console to inspect the network traffic to the http://localhost:8080/geoexplorer/maps/ endpoint. The error message should give you a hint on what is wrong.

  • Yes tomcat7 user has rwx permissions. But using debug tools I get the following error: POST http://83.212.xxx.xxx:8080/geoexplorer/maps/ 401 (Unauthorized) GeoExplorer.js:396 b.sendGeoExplorer.js:396 (anonymous function) – Leonidas Liakos May 10 '13 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.