Using ArcGIS 10.1 for Desktop, I'm trying to run the Identity function on two large data sets but it fails every time. I don't think it is a lack of hardware as I can run other processes on the same data sets.

I've already updated software, and added the 64 bit geoprocessing add-in, checked and repaired geometry, and done the fix in KB29559 (set ARCTMPDIR env variable to a writable local folder).

Executing: Identity DudleyStamp OA2011 "D:\Case Studies\National2\National.gdb\DudleyStampOA11" ALL "1 Meters" NO_RELATIONSHIPS

Start Time: Wed May 08 21:11:43 2013
Reading Features...
Processing Tiles...
Assembling Tile Features...
ERROR 999999: Error executing function.
The table was not found.
The table was not found. [DudleyStampOA11]
The table was not found.  
The table was not found. [DudleyStampOA11]  
Invalid Topology [Topoengine error.]
Failed to execute (Identity).
Failed at Wed May 08 21:45:41 2013 (Elapsed Time: 33 minutes 58 seconds)

Based on comments so far I tried copying data to new file geodatabase, and running the tool from ArcCatalog still get exactly the same error.

I have ordered 16GB of the fastest RAM my computer can take (I current have 4GB). I also have a 6 Core AMD Phenom II X6 1090T, SSD, and AMD Radeon HD 6970 Graphics Card. So I'm not sure what more hardware I can add.

I've also tried increasing the size of the page file which was a suggestion I found on Google with no effect.


2 Answers 2


I would try Repair Geometry first, like you have, but I think the TopoEngine error message is spurious and really this is a resources issue.

Copying the data to a new file geodatabase has sometimes got me past this error so try that first.

Other things I try are rebooting before retesting, running the tool from ArcCatalog or a Python IDE or the command line, rather than ArcMap (if that is what you are doing) i.e. anything you can think of to reduce demand on resources while it runs.

If still no joy, some sort of a tiling and tile visit strategy may be needed.

Also, test on other (preferably more powerful) machines if that is an option because I have found switching to a 12Gb RAM machine usually gets me past this error when I encounter it using 4Gb RAM.


I know that this post is very old, however this issue still pertains in the latest ArcGIS Desktop version 10.6.1. For this particular task disable background processing under Geoprocessing > Geoprocessing options > Background processing and unselect the option Enable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.