2

I have QGIS (v1.8) set up to identify in Top down mode. When I use the identify tool on the map, I frequently get a Bad Allocation exception message and I was wondering what gives rise to this error. It seems to occur, after all layers have been scanned for intersects with the click location (i.e. the status displays as 'identifying done') - it seems to appear when the popup window is being generated.

Any thoughts on what I can try to do to resolve this?

THanks

5
  • What datasource has the layer? I only get Bad Allocation on spatialite databases with huge line geometries when zooming in.
    – AndreJ
    May 14, 2013 at 14:42
  • @Andre they are vector layers (.tab source)
    – Mark
    May 14, 2013 at 14:53
  • Ok, does it help to save them as Shapefile, and work on that?
    – AndreJ
    May 14, 2013 at 16:17
  • Thanks Andre - now tried Shapefile and as a PostGIS layer and still get the same error from all 3 sources. I think that I have narrowed it down to an individual layer (containing a single feature)
    – Mark
    May 15, 2013 at 12:31
  • Workaround - I have split the offending polygon into subpolygons, the select now appears to work
    – Mark
    May 16, 2013 at 9:36

1 Answer 1

2

I'm not sure if your error corresponds to http://hub.qgis.org/issues/3568

There were several Bad Allocation errors in the past (and still active), and they seem to be hard to track for the developers.

The error I encountered with large features in sqlite databases is still active in QGIS Master. I did manage to work around by splitting the feature into several smaller ones (which might not work with polygons).

If you can track down your problem, you could help fixing the bug by adding it to the ticket above, or create a new bug ticket, providing a sample dataset.

I'm afraid thats all we can do at the moment :-(

3
  • 1
    Added to the issues list: hub.qgis.org/issues/7834
    – Mark
    May 15, 2013 at 13:46
  • Can you fill in Platform and version in your ticket? Seems that Ubuntu makes no trouble, while Windows 7 crashes.
    – AndreJ
    May 15, 2013 at 16:55
  • I've updated the form
    – Mark
    May 16, 2013 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.