1

I have created an ImageMosaic with many big pictures, but in GeoExplorer or GeoWebCache this layer is not displayed. If i create an ImageMosaic with only 3 images (from the big ImageMosaic), then the layer displays. Why?

3

1 Answer 1

1

the base error seems to be:

Caused by: java.lang.NoClassDefFoundError: org/geotools/index/quadtree/LazySearchIterator at org.geotools.index.quadtree.QuadTree.search(QuadTree.java:213) at org.geotools.data.shapefile.indexed.IndexedShapefileDataStore.queryQuadTree(IndexedShapefileDataStore.java:828) at org.geotools.data.shapefile.indexed.IndexedShapefileDataStore.getAttributesReader(IndexedShapefileDataStore.java:532) at org.geotools.data.shapefile.indexed.IndexedShapefileDataStore.getFeatureReader(IndexedShapefileDataStore.java:393) at org.geotools.data.AbstractDataStore.getFeatureReader(AbstractDataStore.java:369) at org.geotools.data.DefaultFeatureResults.reader(DefaultFeatureResults.java:214) at org.geotools.data.store.DataFeatureCollection.openIterator(DataFeatureCollection.java:230) at org.geotools.data.store.DataFeatureCollection.iterator(DataFeatureCollection.java:198) at org.geotools.data.store.DataFeatureCollection.features(DataFeatureCollection.java:187) at org.geotools.gce.imagemosaic.catalog.GTDataStoreGranuleCatalog.getGranules(GTDataStoreGranuleCatalog.java:476) ... 109 more

which would only occur if you had lost a geotools jar out of the WEB-INF directory or you have mixed two different versions together.

Are you sure you fetched the version of the plugin that matches your geoserver version?

11
  • Now i have version 3.0.2(Opengeo), but was 2.5, and i install(upgrade) opengeo only(not tools). But why working 126 pics?
    – user15445
    May 15, 2013 at 13:24
  • I'd suspect that the quadtree is only used with more than 128 images?
    – Ian Turton
    May 15, 2013 at 13:40
  • I dont understand, what it mean?
    – user15445
    May 15, 2013 at 13:47
  • if the code never tries to create a quadtree (<128 images) then this error will never occur so it might seem to be working for you with a few images
    – Ian Turton
    May 15, 2013 at 13:48
  • i dont understand too)), and what i must doing for more pics?
    – user15445
    May 15, 2013 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.