I have a "towns" and "state" shapefile for Massachusetts as two separate vector layers in QGIS. I've set the project coordinate system to WGS 84 at the bottom of the screen (next to the "coordinate" and "scale" windows), I've also used the "define current projection" tool under Vector> Data Management Tools. Lastly, I've right clicked on each shapefile in my layers window to "Set Layer CRS." I've also enabled "on the fly" transformations. Is there a common reason why the two shapefiles will not sit atop one another, though I've given them the same projection?

Thanks! Alex

1 Answer 1


Try just setting project CRS and enabling on-the-fly reprojection. Don't touch the layer properties. If the Shapefile .prj definitions are read correctly by QGIS, that's all you need to do.

Similar questions:

  • 2
    one thing to look for is that most (all?) state planes come in feet and meters variants so that two files in state plane A may not line up as one is 3 times bigger than the other
    – Ian Turton
    May 16, 2013 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.