0

The layer being used as the Clip Features has been used before and worked fine, so I assume the issue is the layer I am trying to Clip (Input Features) - I keep receiving the same error when running the Clip tool :

Error 999999: Error executing Function Invalid Topology [Topoengine Error]

The Clip tool has worked fine prior to this. After reading online similar queries regarding this error, the solution in the majority of cases was to change the Input Features to a shapefile - I have done this but receive the same error.

What is my best workaround for this issue?

  • 1
    Very often these errors are a result of projection issues. – Aaron May 17 '13 at 16:36
  • Remember to add the extension of the file, for example, *.tif – Herman Booysen Sep 14 '17 at 8:43
  • I get this error all the time, and usually the aforementioned tricks have worked for me. But today, for some reason and none of those tricks worked. I was ready to pull my hair out, but then I tried doubling the tolerance and that worked. – Jim Titus Mar 25 at 22:10
9

Couple of suggestions:

  1. Run Check Geometry tool on your layer that you wish to clip, you could then follow that up with a Repair Geometry if it finds errors. You may wish to do that on a backed up copy.
  2. Check whether the coordinate systems are different. Perhaps you are trying to Clip a dataset in Decimal Degrees with a dataset that is in Meters or vice versa? If so, reproject the Decimal Degrees data into the coordinate system of the other.
3

ArcGIS often throws a topoengine error when it runs out of memory while running in 32 bit mode and performing overlay operations. To get around that I either chop-up the job or use 64 bit geoprocessing with lots of RAM and Repair Geometry on all input features (create local copies first if you don't want to mess up your inputs with the repair).

2

I ran into the same problem. I tried to clip GeoTIFF raster and keep giving me the 99999 error. I tried several solutions, one of them was to reproject the raster, but didn't work. My output extension was C:\Users*****\Documents\ArcGIS\Default.gdb****_Clip

I changed it to be something like that D:.....wherever you want to save it

I also disable background processing (Geoprocessing > Geoprocessing option > uncheck enable option)

It works right way.

  • I ran into the same error when trying to dissolve a county's worth of road vector data into 1 feature using the Dissolve tool. Before using "Check Geometry" I disabled background geoprocessing and it worked great! I've spent days trying to get this to work! Seemed pretty routine! Didn't need to check or repair geometry. Thanks! – Smithw1 Apr 15 at 15:51
0

Same Problem, using ArcGIS Desktop 10.2.2. (In case clipping big and irregullar shape)

Solution :

  1. Try to split into small part then clip it one by one, and yes it will take a lot of time and work, but it works.

or

  1. Try to clip it using QGIS (I use QGIS Desktop 2.6), I use QGIS and no need to split it one by one. just select area to clip using definition querry and clip.

I recommended try solution number 2.

  • 1
    If memory is the issue, then install 64 bits GeoProcessing and try the clip with it. Having two pieces of software make it complicated further down the road if you have to automate your workflows. Here is the link to the documentation: desktop.arcgis.com/en/arcmap/10.3/analyze/executing-tools/… – Fabien Ancelin Feb 15 '17 at 19:09
  • Thanks for input. But at least its the fastest solution, because if I'm waiting 2017 for your answer then I already got fired. Thanks anyway for information. – Rikudo Pain Feb 16 '17 at 2:38
0

You might need to try Repair Geometry before using Clip http://desktop.arcgis.com/en/arcmap/10.3/tools/data-management-toolbox/repair-geometry.htm

  • This was already mentioned in the most upvoted answer. – PolyGeo Mar 12 at 10:10
-1

Make sure the file name is not too long. Try to rename one of the files and run it stand alone to test results. If you need to rename them, you can use commands in the Powershell or other utilities to rename the files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.