I'm trying to import geometry lines from Oracle Spatial database to ArcGIS enterprise geodatabase.

and some data will cause the error.

Its says not enough points for feature class, but when I look at offending object.

it clearly has 2 or more coordinates stored, but I notice the start and end point is the same.

I have check the following

a) Using geometry filter to take out lines only

b) Use FME inspector to view the lines.

b) Used geometry validator

4) Used duplicate coordinate -> Valid dataset will cause the same error

How can I solve this problem?

May i know is it possible to set FME to skip those data

1 Answer 1


Without seeing your FME Workbench, it's hard to know exactly how to solve your problem. Considering you have tried to filter out the data already, I can think of a few options that might help you:

  1. If you have multiple feature types that you are reading, there is an option in the Workspace Parameters called "Ignore Failed Readers". From the help file:

    This setting tells FME whether or not to continue a translation when reading a dataset fails. For example, if the wrong password is entered so that FME cannot read from a database, should the translation continue with any other datasets that FME can read from?

    Double-click this parameter to display the dialog. Choose Yes if you have specified more than one reader, and you do not want the translation to stop if one of the readers fails or is missing. The default is No.

    Ignore Failed Readers

    Note, this will only work if you have multiple readers.

  2. The other thing you might want to try is a Geometry Coercer. This will force the incoming geometry to whatever you need it to be (lines, for example).

  3. One final thing to look at is the destination feature class. Are you writing to a line feature class? If it's a polygon feature class, that might be giving you the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.