I have a points layer with site attributes and a polygon layer with region attributes. I'd like to join the names of the regions to the point site locations using QGIS 1.8.0., on Windows XP. However, I keep generating an empty shapefile, with no records, but the polygon_region's field names are appended to the end of the points within the empty shapefile. I'm using the default settings for the "Join Attributes by Location" tool. The tool's progress bar indicator seems to advance forward to about 20% complete, then it instantly completes. I'm thinking that it's only processing the header of the shapefile then prematurely "completing"

  • 1
    Are both layers in the same CRS?
    – underdark
    May 21, 2013 at 8:03
  • Yes, they are the same. I also turned off projection on the fly. Is there a particular coordinate system that might be preferred?
    – user12711
    May 21, 2013 at 15:16

2 Answers 2


You may try Hub Distance algorithm in the mmqgis plugin instead. I was facing the similar problem as yours. But then I used mmqgis and this solved the problem for me.

enter image description here

  • This tool might become very handy for me shortly. Thanks!
    – user12711
    May 23, 2013 at 14:50

My problem resolved using the Join Attributes by Points tool:

I had experienced a problem with the output (spatially joined) shapefile being written with header-column-names only, no data. It was skipping attribute creation even though the points geometries fell inside the polygon geometries. I had used and verified the same coordinate system for both layers and turned off On-The-Fly reprojection, to confirm they should join, and to see if the On-The-Fly option could be the culprit, but still no attributes were created for the join.

My solution was to export the data to a new CRS. I used the most common I knew of: [WGS84 (EPSG/SRID/ 4326)] Bingo--It worked!

If anyone experiences zero attribute creation in their spatial join, and they've made sure their CRS for both layers is exactly the same, and have already turned off On-The-Fly re-projection to confirm they should join, but it still fails, then export your data to WGS84 and try that CRS. That was the difference for me. Perhaps the tool has a problem with certain or custom CRS?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.