I've got a python script that is connecting a squence of points to make lines, and putting them into a feature class (based on answers to my previous question). It works wonderfully on a small area that I was using to debug and test (~25 meters, 20 points), but then when I put it into a real-world scenario (~1000 meters, ~500 points), it breaks.

The spatial index grid size is invalid.

Looking into the ArcGIS help suggestions to fix/prevent that, this page suggests recalculating the spatial index grid (directions here), but my polyline feature class doesn't have that option when I am in the "Indexes" tab -- there's no "Recalculate" button at all, and the "Delete" button is grayed out. So how can I fix the error? (I tried simply deleting my original feature class and making a new one, on the theory that my original "little" test case was setting the spatial index grid too small; however, even with a brand-new feature class, I have the same error.)

The problem is more specifically the number of dots I'm trying to connect during one run of the script -- less than ~50 is fine, more than ~100 is not...*

ArcGIS for Desktop with Advanced level license, data stored in feature class in a file geodatabase.

  • Updated the question. – Erica Jun 29 '14 at 19:34
  • 1
    It sounds like you are in a good position to be able to post a working code snippet here that reproducibly demonstrates this problem. The same error is mentioned in Esri Technical Article 35007. – PolyGeo Jun 29 '14 at 21:21
  • This is from over a year ago; I know what script I was working on and talking about, but will need to look around for quite a while to find the version that was dysfunctional. I'll get it eventually, though :) – Erica Jun 30 '14 at 11:29

I recently ran into this problem and was able to solve it by deleting the spatial index on the feature I was trying to edit. For reference I'm working with features in WGS84 (EPSG:4326).

  • Such a simple solution. Worked for me. – Tom May 31 '16 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.