Why for some of my most used CRS the 'towgs84' part of the definition of the layer spatial reference system is missing, compared to the QGIS for Windows?

EPSG 3004, 23032, 23033 when used with QGIS for Ubuntu are missing the 'towgs84' definition part, that is present in QGIS for Windos. Why this?

I've experimented this with QGIS 1.8 for Win and QGIS 1.8 and 1.9 Master under Ubuntu 12.04

1 Answer 1


The CRS database of QGIS normally gets syncronized against the GDAL/PROJ CRS definition files at the end of the installation process. If the installation fails, or you had an older version of GDAL/PROJ installed on Ubuntu, you might have outdated CRS information stored in the database.

As a workaround, you could make a copy of C:\Programme\QuantumGISLisboa\apps\qgis\resources\srs.db, look for the same file in the Ubuntu file system (probably /usr/share/qgis/resources) , make a copy of that too, and replace the Ubuntu with the Windows one. You might need admin rights for that.

You could as well open and edit the srs.db with spatialite gui.

  • thank you, I don't know why as GDAL install was successfull. Anyway tried to copy the Win srs.db but I get an error in QGIS Ubuntu, probably due to the difference in versions of QGIS. I'll try to modify the db manually.
    – stefan0n
    May 23, 2013 at 13:21
  • I tried the same, got an error of missing rights. The other way round it works. But my Ubuntu QGIS Master has towgs84 values. I used the 'ubuntugis-unstable' ppa for Lisboa and qgismalaysia.blogspot.de/2012/04/… for Master to install.
    – AndreJ
    May 23, 2013 at 15:29
  • I wasn't able to solve this definitively yet, also with a fresh install of QGIS 2.01, towgs parameters are still missing.
    – stefan0n
    Feb 3, 2014 at 11:53
  • Not sure what went wrong at your side. I have installed QGIS 2.0.1 on Ubuntu 12.04 from ubuntugis-unstable, version 2.0.1-1~precise1, and the +towgs84 parameters are there.
    – AndreJ
    Feb 7, 2014 at 16:22
  • Hi Andre, finally solved here too! Using ubuntugis repository solved, while using qgis.org/debian lucid main still installs GDAL 1.7.3 and no +towgs84 parameters for the CRSs of my interest.
    – stefan0n
    Feb 10, 2014 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.