I am attempting to call do a GetFeatureInfo request on it a counties layer which is stored withing ArcSDE and hosted via ArcGIS Server 10. The request looks like

WMS GetFeatureInfo Request

The county web service was created by way of ArcMap with the save service definition file. However, no data comes back with attempting to do run this command. Are there any settings on ArcGIS Server specific to whether a service can have GetFeatureInfo run on it? I was expecting values from the attribute table to come back.

Thanks, Derek

  • I think part of you command may have been truncated. It has a large space and no getinfo section. If you could fix that and verify that you have selected the ogs (WFS) section of the service parameters. I think that is the level you need to use to getinfo. – Brad Nesom May 26 '13 at 22:52
  • I removed the space. I have changed the server name to be generic as I just wanted to show the request parameters that are being sent. Also, I have tried this request directly on the ArcGIS server to verify that it is not a cross-domain issue. I am still perplexed as to why nothing is returned. – geo derek May 26 '13 at 23:00
  • Did you check WMS as a capability when you published the map service? See help. – Kirk Kuykendall May 26 '13 at 23:03
  • I did check the capabilities and they all see to come back fine: mist.nemac.org/ArcGIS/services/OptIn/OptIn_Viewer1/MapServer/… – geo derek May 27 '13 at 0:20
  • I see a stray comma in the styles section. I can't get it to work but figure it is just a malformed request. – Brad Nesom May 27 '13 at 5:52

Esri help for 10.0 can be found here.
You may need to configure the capabilities.
This is a sample get capabilities call to the rest endpoint. I am not an (OGS) expert but don't think you have a complete call URL.

esri sample GetCapabilities from help

If your capabilities allow it. You can make the getfeatureinfo call with this sample.

esri sample GetFeatureInfo from help

Now I get an error on the srs being empty.
see if that helps any.

updated Almost


I tried the request you posted in the comments above and got the same until I replaced the encoded ampersands (replaced "&" with "&"). I was able to get a response, but there were no features at that x/y location.

I then constructed a corresponding GetMap request, removing the stray comma in the STYLES parameter, as follows:


Then, I simply modified your GetFeatureInfo query to use X/Y pixel values that intersected the line, and it worked:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.