I'm an iOS programmer but new to using ArcGIS 10.1. I'm having a problem loading my MicroStation dgn file to ArcCatalog. I've connected the folder containing my MicroStation V8i roadway design dgn to the Catalog Tree and tried to define a spatial reference as described in the ArcGIS 10.1 Resource Center. When previewed, the drawing looks like a small blob that I can't zoom or view. I'm stuck to determine what the problem is. I'd think that the drawing should display in full as read only. If anyone as any suggestions I'd greatly appreciate some direction here.

Overall, I hope to overlay the dgn (drawing) over one of ArcGIS' basemaps.

I can supply any information about my dgn or setup in ArcCatalog upon request. Thanks in advance for your time.

*Here's a screenshot of how the preview of the drawing looks.


I think the blob on the right hand side is the drawing but I can't be sure what's all there because I can't zoom in to see it better.

| improve this question | | | | |
  • Was the Microstation file created and drawn in real world coordinates? If it was not, setting a spatial reference in Arc on the file will do nothing for you. Most of the CAD data our office receives from engineers and surveyors is missing this key component, making the data useless to us at that point. – Lemur Dec 6 '13 at 15:34
  • 2
    I've been working many years with Microstation v8 DGN files,and there is all kind of compatibility problems with any non Bentley software. My recomendation is to transform your DGN files to another CAD format, like Microstation v7 or DWG. – cag May 20 '14 at 8:59

I would advise using ArcMap rather than ArcCatalog for this - simply Add Data it, or drag and drop from its location in the Catalog window of ArcMap onto the map canvas.

This part of the Online Help is well worth a read.

| improve this answer | | | | |
  • Thanks for the response. I've looked through much of the ArcGIS Resource Center for information regarding CAD Integration and it seems to assume your drawing file properly displays soon as you add it to ArcMap. I'm hung up on this first step. I tried adding it directly to ArcMap but it displays the same as it did when I tried in ArcCatalog. Is there anything I can check in ArcMap settings or file properties to make sure the file is in good working condition? – user18657 May 30 '13 at 23:41
  • By "properly displays" I am assuming that colours etc are OK (you can Zoom To Layer to check) and it is just that the coordinates do not look like they are in the real world. If that is the case have you followed the procedure to Georeference a CAD Dataset here? – PolyGeo May 31 '13 at 0:02
  • Poly. I updated my question to include a screenshot of the preview of my drawing. – user18657 May 31 '13 at 2:24
  • @user18657 I have only just seen your comment and your drawing seems to be inaccessible. Can you please replace the link with a picture embedded in your question using the Picture button. – PolyGeo Mar 20 '16 at 5:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.