1

I am trying to remove the security from web services.While seaching , I found that we have to set

<SecurityEnabled>True</SecurityEnabled>

                  To

<SecurityEnabled>False</SecurityEnabled>

Now after replacing this true with false , I saved the file. Now when I restart my computer and reopen this file, It is again set to <SecurityEnabled>True</SecurityEnabled> .I am unable to understand why this is happening?

  • I think you need to stop manually ArcGISSOM ans ArcGISSOC services then modify the file and restart service. To perform this you need to Admin access.. – Sunil May 30 '13 at 5:30
  • +1 similar article and I assume that you are ArcGIS Server 10. forums.esri.com/Thread.asp?c=158&f=1696&t=280859 – Sunil May 30 '13 at 5:35
  • Yes I have ArcGIS server 10.Let me see the post – Despicable May 30 '13 at 5:40
1

There are some more steps you are supposed to get done. From the Esri Help:

Once you enable security for GIS services, you cannot use Manager to disable security. This is to prevent accidental disabling of security and exposure of access to your services. If you decide later that you must disable security, you can do so with the following steps. CautionCaution:

If you perform these steps, any user is able to connect to any GIS service using an Internet connection without providing any login.

Open the Services management console by clicking Control Panel > Administrative Tools > Services.
Right-click the ArcGIS Server Object Manager service and click Stop.

If you make the changes below before stopping ArcGIS Server, your changes will be overwritten when ArcGIS Server stops.
Use a text editor (such as Notepad) or XML editor to open the file Server.dat on your server object manager (SOM) machine. This file is located in your ArcGIS Server installation at <ArcGIS Installation Location>\server\system.
Change the following element, located inside the <Server> element, from

<SecurityEnabled>true</SecurityEnabled>

to

<SecurityEnabled>false</SecurityEnabled>

Save the file.
Use a text or XML editor to open the file web.config in C:\Inetpub\wwwroot\ArcGIS\Services (adjust the path if you installed the ArcGIS Web services to a different location).
Locate the following line within the <appSettings> section:

<add key="RequireToken" value="True" />

and change it to

<add key="RequireToken" value="False" /> 

Save the file.
Repeat the previous two steps for the web.config files in the Rest folder and also the Tokens folder in the C:\Inetpub\wwwroot\ArcGIS directory.

If security was configured for Windows users, reenable anonymous access to the Services and Rest folders in the ArcGIS Server Web instance in IIS. Refer to the instructions in the section entitled Disabling anonymous access to ArcGIS Web services in Internet Information Services, except in step 3 of the instructions, choose to enable anonymous access. Do this for both Services and Rest directories.

Return to the Services management console, right-click the ArcGIS Server Object Manager service and click Start.
Right-click the World Wide Web Publishing Service and click Restart.
  • yes I have already seen this but I a unable to find the web.config file. – Despicable May 30 '13 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.