I apparently have a problem with getting meaningful scalebar values referred to a shapefile in QGIS. I think I tried all solutions suggested in other discussions, but still I don't get it. I use QGIS 1.8.0 Lisboa. The shapefile was downloaded from a reliable source (DIVA-GIS.org), it is a typical administrative areas polygon.

In case anyone wants to try it, here it is:


When it was downloaded it came set with WGS84. I set the Project settings to: on the fly projection enabled, Project CRS WGS84/UTM ZONE 33N.

I set the layer CRS to WGS84/UTM ZONE 33N.

Then I "zoomed to layer" extent and added the scalebar: it reads 10 meters. Whole China seems to span east to west about 60 meters.

I also tried to "save as" the shapefile with WGS84/UTM ZONE 33N, got a new shapefile and the new shapefile behaves just the same.

There must be a mistake I am doing, but I can't find what.


1 Answer 1


Don't change the layer CRS! By changing the CRS in layer properties, you are telling QGIS to assume a wrong CRS. Just enable on-the-fly that's all.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.