1

I have a number of shapefiles from a customer. I can read them with both ogrinfo and QGIS.

They don't have a .prj file, but I know that the projection is EPSG:3006.

When I add them as layers in GeoServer, I declare the projection to be EPSG:3006 in the box "Declared SRS" by inputing "EPSG:3006". I set "SRS Handling" to be "Force declared".

It makes no difference if I add a .prj file with a projection definition. I can then calculate the bounds successfully.

When I try to preview the layer in OpenLayers, I get an empty map. When I try to load the layer as WFS, I get an empty result.

There are no error messages in the logs as far as I can see. I have tried to change the log level.

If I run ogr2ogr and save them as new shapefiles, they work in GeoServer. If I export them to a new shapefile from QGIS, they work in GeoServer.

Is there a way I can use OGR or QGIS to show my customer what the problem is?

  • 1
    how do you "declare the projection to be EPSG:3006"? – Ian Turton Jun 3 '13 at 15:31
  • I edited my question to expand on this. Short version: I use the Declared SRS box. – Peter Thorin Jun 4 '13 at 5:54
  • can you post the ogrinfo output – Ian Turton Jun 4 '13 at 7:18
  • Unfortunately not since it is customer specific data. – Peter Thorin Jun 4 '13 at 8:57
1

Turns out the problem was that in the original file, record numbers start at 0. Geotools (used by Geoserver) doesn't like this, since the specification states that record numbers start at 1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.