I'm labeling features in a map book (MapLogic) in ArcMap using Maplex labeling. I have the "Never Remove..." box checked within Maplex for the layers, however, some of my features that have a very small area (e.g. 0.005 sqft) are missing labels - they're just not placing. All labels are dynamic.

When I try to create annotations for those layers (tried selecting just the features whose labels weren't placing, and all the features within the map), no annotations were created for those unplaced labels (even when I selected 'create annotation for unplaced..')

Is this a bug that others have experienced, or is there some tweek within Maplex settings that I need to do?

Here're a few screenshots of one of the layer's Maplex label settings that won't place - the feature's area is <0.005 sqft.

EDIT: This is in ArcGIS 10.1





  • Looks like there's some discussion about this same proble here: gis.stackexchange.com/questions/9468/… ...however, doesn't look like there's a definite solution. Looks like creating an annotation db is the next best solution?
    – geominded
    Jun 7, 2013 at 19:38
  • 1
    Are any of the features by chance, multi-part features, where they are getting labeled in other locations? Or have you tried the standard label engine to identify that they will label using a different engine? Jun 7, 2013 at 19:43
  • No multiparts - already exploded. They won't place using the regular label manager either.
    – geominded
    Jun 11, 2013 at 19:57
  • Can you post a small sample dataset for community investigation? Just scrub all of the attributes, and even randomly move the features if needed? Jun 11, 2013 at 21:01

1 Answer 1


Rather than forcing the over run option.
Try the external zones. Make sure they are are not set to block.
Also use a .00022 in the minimum feature area. (You have it set to map units and you are missing polygons <.005).

Use "may place label outside polygon boundary".
Then set anchor point. Try the closest on the polygon boundary. But you could try each different one.

Sometimes all the settings in maplex can push and pull against each other.
Maybe releasing some of the restrictions and just getting everything to label.
Back down from there to get just what you need.

Worst case scenario.
Turn off maplex and. Set place overlapping. You should get an ugly mess with every label.
Unless your value or expression has a problem in it?

  • 1
    I've played around with the settings. Each time the labels are moved, but, unfortunately, even on the most basic settings the labels for the tiny features are not showing up. I think an annotation db is really the only sure option to place all labels.
    – geominded
    Jun 12, 2013 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.