I would like to work with some of the Michigan state data (for example, this shapefile of cities ), but it is not in a common projection. However, when I try to reproject the file using ogr2ogr and any one of the possible EPSG codes, I get a map that is anywhere from rotated & skewed to flat:

ogr2ogr -s_srs EPSG:102121 -t_srs EPSG:4326 city_mi_84.shp city_mi.shp 

Any suggestions on how I can make this work? I don't have access to Arc at the moment.


I also am in Michigan, and working with MI GeoRef data is always a bit of a problem when I use QGIS and other programs that rely on GDAL/OGR conversion utilities. You might try EPSG:3078 as the source projection if it's the non-HARN MI GeoRef ("NAD 83/Michigan Oblique Mercator"), and EPSG:3079 as the source if it's the HARN version ("NAD 83(HARN)/Michigan Oblique Mercator") you want. These, to the best of my knowledge, are the "correct" EPSG codes to use as source projections representing the regular and HARN versions of NAD 83 MI GeoRef.

Having said that, my experience in using them in QGIS has been mixed. I often use the *.ecw aerials from Michigan CGI as the base image layer. QGIS support for *.ecw files is also somewhat shaky. Combining the two sometimes produces strange, skewed results.

Good luck, and please post a reply here if you succeed with EPSG 3078 and/or 3079 !

UPDATE 5:13 pm 19 Feb 11: Matt, if you try

ogr2ogr -a_srs EPSG:4326 [outputfile] [inputfile]

(i.e., leave out the "-s_srs" and "-t_srs" parameters and use "-a_srs" instead)

then the result plots (seemingly) correctly using QGIS, but then it won't work with any other layer. Sigh...

  • Thanks for the helpful suggestion! I tried with 3078/9 and alas, I still got the flattened out maps. Here's what I ran: ogr2ogr -s_srs EPSG:3079 -t_srs EPSG:4326 cities_84.shp city_mi.shp. Funny thing is that QGIS displays the original files just fine, I just can't seem to reproject them correctly. – Matt Hampel Feb 19 '11 at 19:43
  • Have you checked that your installation has the datum shift grids installed? – scw Feb 19 '11 at 21:42
  • I do have both in my /usr/share/proj/epsg folder: # NAD83 / Michigan Oblique Mercator <3078> +proj=omerc +lat_0=45.30916666666666 +lonc=-86 +alpha=337.25556 +k=0.9996 +x_0=2546731.496 +y_0=-4354009.816 +ellps=GRS80 +datum=NAD83 +units=m +no_defs <> # NAD83(HARN) / Michigan Oblique Mercator <3079> +proj=omerc +lat_0=45.30916666666666 +lonc=-86 +alpha=337.25556 +k=0.9996 +x_0=2546731.496 +y_0=-4354009.816 +ellps=GRS80 +units=m +no_defs <> – Matt Hampel Feb 20 '11 at 15:45
  • Also, I see the same behavior with the 5:13 update (above) -- the data displays fine in QGIS, but I can't use it with any other layer or in other apps. No errors given, and the metadata says wgs84. – Matt Hampel Feb 20 '11 at 16:26
  • 1
    This type of behavior's been discussed in the QGIS forums before, and the QGIS devs point to GDAL implementation of GeoRef. Those of us in MI are really in a quandry as the best way to use State-supplied GIS shapefiles on QGIS is to convert them to State Plane or WGS84. But the GDAL utilities can't seem to handle GeoRef at all. (Plus the fact that the state distributes aerials as *.ecw files, which is somewhat problematic as well in QGIS.) – Howard Y Feb 20 '11 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.