I am trying to update a Point inside my PostGIS database that is connected with GeoServer.

I specify the new coordinates in the WFS-Transaction post message like this:

<gml:Point srsDimension="2" srsName="urn:x-ogc:def:crs:EPSG:4326">        
<gml:coordinates decimal="." cs="," ts=" ">0,0</gml:coordinates>

This works just fine.

However I am confused about the next step. The Points inside my PostGIS database are not in EPSG:4326 but EPSG:28992. So I tried changing the srsName to EPSG:28992 but this just makes GeoServer throw an exception.

How am I supposed to update Points using the EPSG:28992 projection?

If I update the points using srsName="urn:x-ogc:def:crs:EPSG:4326" GeoServer throws an PointOutsideEnvelopeException which is understandable.

Am I missing something here? Can I only update points using EPSG:4326?

  • are you putting urn:x-ogc:def:crs:EPSG:28992 or just EPSG:288992?
    – Ian Turton
    Jun 17, 2013 at 14:43
  • urn:x-ogc:def:crs:EPSG:28992 Jun 17, 2013 at 14:43
  • try just EPSG:28992
    – Ian Turton
    Jun 17, 2013 at 15:44

1 Answer 1


I changed the WFS version from 1.0.0 to 1.1.0 and it works now.

I also set the native srs to EPSG:28992 in GeoServer.

  • that would make sense - 1.1 adds the concept of reprojection and without the native projection set GeoServer probably guesses wrong
    – Ian Turton
    Jun 18, 2013 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.