2

Why can't I click any of the tools under "Edit?" I want to merge selected shapefile layers together, but all of the tools under "edit" are greyed out.

3
  • 1
    Welcome to GIS SE. What GIS application are you referring to (e.g. ArcMap, QGIS..etc)?
    – artwork21
    Commented Jun 18, 2013 at 15:58
  • QGIS. I'm trying to use Edit> Merge Selected Features
    – Alex
    Commented Jun 18, 2013 at 16:00
  • I've realised that you also have to Select the polygon too. it worked for me :)
    – user30395
    Commented May 19, 2014 at 16:59

3 Answers 3

6

Right click on the layer you want to edit in layers panel, and select "Toggle Editting" when the context menu shows. Then the "Edit" menu will be enabled.

2

You must "Toggle Editing" before any of the edit tools are available.

2
  • Mingfeng beat me to it by seconds! Commented Jun 18, 2013 at 18:30
  • @Alex Please upvote helpful answers and accept questions that solve your problem so the thread can be marked as solved.
    – underdark
    Commented Jun 18, 2013 at 19:31
1

Fyi if you're trying to merge lines in a kml it won't work, you need to convert to another file type and then convert back (it seems)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.