2

I am on Ubuntu 13.04. I get the following error message -

    Traceback (most recent call last):
      File "analyse.py", line 1, in <module>
        from log import shelve
      File "/home/shubham/SMART/TaxiData/log.py", line 27, in <module>
        from demo import *
      File "/home/shubham/SMART/zones/demo.py", line 5, in <module>
        from qgis.core import *
    ImportError: No module named qgis.core

Actually, everything was working fine till today morning. I guess this might be due to a package update.

The qgis version I am using is 1.8.0-2~raring1. The remote repository is http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ raring/main amd64 Packages.

I tried looking around on Google but my search was fruitless. So, I will really appreciate any help or pointers you guys can give :)

Thanks.

3
  • Can you add the QGIS version you are running, and what repository you used? – AndreJ Jun 19 '13 at 17:00
  • @AndreJoost - I have added that information. Thanks for trying to help :) – Shubham Goyal Jun 19 '13 at 17:17
  • The problem also occurs with the QGIs-master (after updating from build 313) and on older Ubuntu's, e.g. 12.04, on my machine. Stefan – user19325 Jun 20 '13 at 21:41
2

You are not the first with that problem, see "Ubuntu 13.04 and QGIS" at qgismalaysia.blogspot.de

There have been some python API changes, which have not been solved for QGIS Lisboa. And awaiting QGIS 2.0, I'm afraid they may not be solved.

(That's why I like my Windows installation: No automatic updates spoiling the running application)

You can try the repository at http://qgis.org/debian raring main after deleting your broken installation, or set up a virtual box with a separated Ubuntu 12.04, like I did.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.