4

The background: I have an .mxd that I intend to roll out across the company as our default template for all future maps/figure production. This .mxd contains two Data Frames; the first ("Main") is larger (occupying almost the entire page) and is designed to be used to hold the majority of mapped data whilst the second ("Inset") is much smaller and is to be used as an overview map.

The problem: When choosing to import this new .mxd to an existing .mxd (using the Change Layout button on the Layout toolbar) the wizard automatically selects the smaller ("Inset") Data Frame to occupy the larger part of the page. The screenshot below shows this interface with a red box indicating the two possible locations of each Data Frame:

enter image description here

The question: Whilst it is possible to manually alter the order of the Data Frames using the Move Up or Move Down buttons I would like to know how to change the default option for this setting (i.e. so that the "Main" Data Frame always appears in the larger space - "2"). The reasoning is that I would like the process of using this new .mxd template to be as simple as possible, this is especially important as we have a wide range of users with varying abilities.

Does anyone know how to choose/change this default setting? It does not appear to be in the Data Frame Properties > Data Frame menu where I would expect it to be.

3

In your template mxd, the inset data frame should be placed before the main data frame. When your users import the template, the inset will move to position 1, and the main data frame will be in position 2.

enter image description here

When applying the template to an mxd with a single data frame, the default layers data frame will occupy the inset position.

enter image description here

  • Very helpful, thanks. It does seem strange that there is not an option to order your Data Frames in the Data Frame Properties menu! – veedub Jun 21 '13 at 11:09
3

I found a way to change the data frame order in your template. You can right click on the main data frame in layout view and chose 'order' --> move to front. Like this the main data frame will have position 1, when it comes to the 'Data fram order' window.

However, this will only work if your 'insert' data frame is not overlaying the 'main' data frame on your layout. Because if they are overlaying, the 'main' data frame will cover the 'insert' one.

Thought it might be helpful to people with a different setting as I have.

Cheers Simon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.