I was wanting to know if anyone could explain why the only capability showing when I try to publish an ArcGIS Service is Feature Access (Picture Below). I am needing to create a service that will allow the user to update, add, and delete attributes from a feature layer. I have the database registered, but the only Feature Access capability I am able to access is the ability to query. Any help would be appreciated.

enter image description here

  • Is your data published from a SDE database, if so does the published connection have edit rights on the data set?
    – user19331
    Jun 21, 2013 at 3:34
  • I face the same problem. Have you solve the problem? Thanks.
    – user21863
    Sep 10, 2013 at 11:59
  • Not entirely. It seemed to be connected to how my service is set up. I would recommend publishing the service and then see if you can change the capabilities from the manager. None of the answers below fixed my problem, but could be the answer to yours. @user21863 Good luck!
    – JLott
    Sep 10, 2013 at 13:34
  • Did you ever figure this out? I'm having the same issue, but with PostGres.
    – ianbroad
    Jan 23, 2014 at 17:41
  • Yes, but none of the answers below fixed it.. I had to also make sure that all of my settings were correct before it would work. I am not familiar with PostGres, but I could possibly help you set things up if it is similar to ArcMap/AcrGIS for Server.
    – JLott
    Jan 24, 2014 at 15:32

6 Answers 6


She doesn't want to publish a feature service, She is just trying to publish A service. I passed through the same exact situation with my ArcGIS for Server 10.2 trial version. Everything was going fine and I was able to publish and read my services. One day, I tried to connect to the ArcGIS for Server Manager and there were no services. I bet if you tried to connect to your Manager you will not see any services either, even though you have published some before. I even tried to publish a simple map service and all what I got is this Feature Access capability.

I later discovered that my ArcGIS for Server license was expired so I renewed it, and reauthorized my software. It doesn't have anything to do with basic or enterprise license, it was simply expired. So, the thing is that your ArcGIS for Server is either expired, corrupted for some reason or, well you did not license it in the first place.

I would suggest getting your license file again, and re-run the Software Authorization process. In the Software Authorization Wizard, select I have received an authorization file .... then select your authorization file, which is an ECP file.

First HRESULT, and now this. ESRI really ought to work on displaying proper warning and error messages.

enter image description here


What license/edition level do you have? According to this brochure, the basic license for ArcGIS for Server doesn't support a read/write feature service. If you don't have the standard or advanced edition, web editing isn't supported.

  • I have the EDN License for ArcGIS for Server Enterprise Advanced.
    – JLott
    Jun 20, 2013 at 17:45
  • Well, there goes that idea! <grin>
    – mkennedy
    Jun 20, 2013 at 17:50
  • Yep haha :P I have tried everything that I can think of. It makes no sense to me.
    – JLott
    Jun 20, 2013 at 17:51

I would recommend first checking what license you have really installed by looking at the C:\Program Files\ESRI\License10.1\sysgen\keycodes file. There you can see what license you have really installed. Another thing is to use ArcGIS Server Manager > Site > Software Authorization panel which also gives you overview over what licenses you have for your ArcGIS Server site.

If you do have Enterprise Advanced and when publishing a map service don't see Mapping capability available, this may sound to me as software has not been installed properly or has been corrupted afterwards. Try reinstalling the ArcGIS Server then.


This problem is seen when the connection is set to 'administrate', so what needs to happen there is it is to be set to 'publish'.


Similar to the above answers, you definitely need at least a standard level license to be able to even so much as publish a feature service. Provided you have a standard or advanced level license, you also need to ensure you data is registered with the server (which you say it is) and registered as versioned. If it is not registered as versioned, you will not be able to edit the data in ArcMap and most definitely will not be able to edit the data through a feature service.

In summary, here is what to check.

  1. ArcGIS for Server Standard or Advanced License
  2. Data stored in SDE Database
  3. Feature Class registered as versioned
  4. Database registered with ArcGIS for Server

Good luck, hopefully this helps!

  • Publishing as a Feature Service was not my initial issue. I was confused as to why the only capability that was showing was the Feature Access.. I am not sure which issue the user who set up the bounty is having though.
    – JLott
    Jan 24, 2014 at 15:35

I was facing the same problem on a Virtual machine. For me, the following worked: **sharing the folder C:\AGSData with "Everyone".

enter image description here**

I would have prefered to share it with ArcGIS Server Account but for some reason, I got a message that Windows was unable to find that account. Nervertheless, sharing with everyone worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.