9

So far I have found instructions on stack exchange but they are for windows. And so far the information I have found is for windows. I currently have Ubuntu 13.04 Raring tail. I am using qgis 1.8. I understand that gdal automatically comes with it and I should be able to open it(.gdb). I have the .gdb file on my computer. I have tried add vector layer and source type as file and Database and directory. The option for database wants to me connect to a server but I don't need to.

Installing File Geodatabase (*.gdb) support in QGIS?

Open Source Tool capable of reading Esri File Geodatabase (.gdb)?

I tried to install ubuntu gis ppa, the stable and unstable version, this actually caused qgis to lost the python plugin option and I have to do a clean uninstall. sudo apt-get remove --purge qgis

https://launchpad.net/~ubuntugis/+archive/ubuntugis-unstable

I did read this on stackexchange: Migrating geodatabase data into PostGIS without Esri apps?

This maybe my answer but does he mean put that in the terminal?

  • Here is the exact error message:is not a valid or recognized data source – T.J. Jun 20 '13 at 18:34
  • What is the version of your File Geodatabase? They need to be at least version 10.0, as prior versions are not supported by the API. – Get Spatial Jun 20 '13 at 20:21
  • I am using Arc GIS Desktop 10.1 – T.J. Jun 20 '13 at 20:24
  • What is the source of your file geodatabase? Did you create it, or did it come from somewhere else? I understand that the software you are using is version 10.1, but you need to ensure that the version of the file geodatabase is at least 10.0, and that it was not created with a prior version. – Get Spatial Jun 20 '13 at 20:31
  • No, I created it using the 10.1 software maybe 2 weeks ago. – T.J. Jun 20 '13 at 20:35
3

I know it's been a while since this question was asked, but I was having similar problems (albeit with 14.04) and thought I'd post my solution.

I also had QGIS 1.8 installed (and later again tried this with 2.18 to no avail), and the solution given by jbalk did not work because this option didn't exist in the drop-down list. While the OpenGDB driver is installed in QGIS by default, it is only the case when it is compiled against GDAL version 1.11.0 or higher (see RyanDalton's comment on File Geodatabase (*.gdb) support in QGIS?). When installing the stable version of QGIS version according to the QGIS website instructions, I ended up with a GDAL version of 0.9.#.

You can check your GDAL version by typing

gdalinfo --version

The easiest way to fix this now (perhaps this update didn't exist back in 2013) is to install using the ubuntugis-based repositories according to the instructions on the QGIS website. The GDAL version will then be up-to-date (mine currently reads 2.1.0), the OpenGDB driver will work out of the box, and you can follow jbalk's instructions.

1

Layer > Add Vector Layer > Directory > Type: ESRI FileGDB > Navigate to gdb folder, highlight and press OK.

Since you asked the question, QGIS has been updated several times and FileGDB support has improved. Please reinstall QGIS and try the above procedure and post screenshots if you get any errors.

0

In 2019 with qgis 3.6, you can do this!!!!

Step 1: click the add vector button (red circle)

enter image description here


Step 2: select directory, openFileGDB, and file path (red arrow)

enter image description here


Step 3: select all layers (red circle) enter image description here


Done!!!!! You just add all layers to qgis

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.