1

We are using MATLAB to request a combined WMS from GeoServer. The request is auto-generated as this:

http://geo-pprod.test.cresis.ku.edu/geoserver/arctic/wms?SERVICE=WMS&LAYERS=greenland_natural_90m,rds_line_paths&CRS=EPSG:3413&FORMAT=image/geotiff8&HEIGHT=527&BGCOLOR=0xFFFFFF&REQUEST=GetMap&WIDTH=620&BBOX=-1465312.4055326465,-3439603.5364015717,1669546.4179967656,-774973.5364015717&STYLES=,&VERSION=1.3.0

It's requesting a GeoTIFF store with a linestring (PostGIS store) both published in EPSG:3413.

greenland_natural_90m: Greenland GeoTIFF (declared native as EPSG3413)

rds_line_paths: PostGIS linePath geometry table (re-projected from WGS84 to EPSG3413)

The result from this request looks like this:

http://i.imgur.com/FSC6fcQ.png

However when I load the same two layers in our OpenLayers web client I get the following (correct):

http://i.imgur.com/rsr8XTF.png

Note that we have tried every image format and get the same results. We have also tested on multiple versions of GeoServer. Any help would be appreciated. Unfortunatly our server in not public yet so please keep that in mind if additional information is needed.

What we have tried:

  • View in OpenLayers (works)
  • Get each layer individually (works) **We really need it combined
  • Get layers (combined/individual) in multiple formats (Works individual, fails combined in MATLAB)
  • Revert to old versions of GeoServer (this has worked before, but continues to fail now)

Notes:

We are running Geoserver 2.3.2 WAR served via Tomcat6 through Apache on an RHEL linux server.

  • do you have to use FORMAT=image/geotiff8? Try one of the better known/supported formats – Ian Turton Jun 23 '13 at 12:57
  • We have tried all formats from img/jpeg img/png img/geotiff etc... All have the same result. – Kyle Purdon Jun 23 '13 at 16:34
  • what is the difference between the working (openlayers) and non working request URL's – Ian Turton Jun 23 '13 at 18:51
  • Request wise, nothing. However OpenLayers hits GeoServer with two get layer requests and then combines. MATLAB hits with one multi-layer request. This has worked for us in the past and seems to not be working now. We have eliminated any/all changes we have made as possibilities. – Kyle Purdon Jun 23 '13 at 23:01
1

For those in the future here is what I did.

It seems something ArcGIS was doing created a conflict with geoserver. So I used QGIS to re-create the GeoTIFF files making sure to create the TFW -co TFT=YES and all seems well now. This really doesnt narrow down what my issue was but really gives me another push away from commercial software towards a fully FOSS life!

Thanks for all that contributed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.