1

I am attempting to run a spline interpolation on a point dataset of 585 features in ArcGIS 9.3, using the spatial analyst toolbar.

The dataset holds only latitude, longitude and abundance attribute data (all as 'double' field type), in addition to the standard 'FID' and 'Shape' fields. I have successfully run IDW and natural neighbour interpolations on the data, but whenever I attempt to run a spline interpolation, Arc returns the error '#010067: Error in executing grid expression'.

The aim of this interpolation is to model fish abundance data across the North Sea and eastern English Channel, whilst producing as smooth an output as possible (hence dissatisfaction from my bosses with the natural neighbour and IDW interpolations).

I have queried the error and common responses on the ESRI forums suggest either a) illegal characters are used somewhere in the filename/attributes/file path; b) the output raster name is too long or c) the shapefile has coincident points.

I have tested these theories by firstly making a copy of the shapefile and saving it to 'C:\', with no illegal characters. This produced the same result. I also had a raster name of three characters - 10 under the 13 limit. The shapefile also has zero coincident points. Some are close, however, so I ran the spline on a 'thinned out' dataset, with only disparate points. Again, I received the error '#010067'.

Does anyone have any suggestions? I have run a spline interpolation on a test dataset that I created, just to be sure the tool wasn't in some way erroneous, but that ran without issue.

  • If you are saving the output to a GDB, make sure you are set to overwrite any other datasets with the same name or a unique name, even if they are located in different raster dataset "sub-folders". – Jason Jul 2 '13 at 15:19
  • Hi @Jason - thanks for your comment. I am saving to ESRI raster format, in an empty folder, with a unique name. – the_bonze Jul 2 '13 at 15:25
  • Also check to make sure your output raster name does not begin with a numerical value. Can you provide more details with the exact path and filename you are trying to use? Other inputs the tool is asking for and your supplied values? – Jason Jul 2 '13 at 17:49
  • The raster file name starts with an 's', and is part of a filepath that's 204 characters long (I can't provide the specific path due to client confidentiality). There are spaces and ampersands in the filepath. However, I have written rasters to the same filepath for natural neighbour and IDW interpolations. I have the same error when writing to 'C:\'. The tool asks for the shapefile and attribute column as inputs, as well as output location and two interpolation factors (I have tried both default and my own values here). – the_bonze Jul 3 '13 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.