2

I'm using Qgis master on Windows 7 and more recently xubuntu 13.04. On xubuntu, the 'fetch python plugins' is missing, which Nathan just pointed out was intentional rather than a bug. My problem is that on xubuntu, Qgis searches the repository with unchangeable query switch

?qgis=2.0

This means the majority of plugins aren't available. Maybe I'm being really dumb here, but these work on my windows machine as I can install them through the python installer. Aren't 1.8 plugins mostly/all compatible with 1.9? Is there any workaround? When v2.0 hits, will all plugin developers have to have upgraded their plugins for compatibility?

Thanks!

Dez

3

1.8 plugins will not work in 2.0 (1.9) without being updated.

The API has changed requiring all plugins to be updated before they will work in 2.0. The filter string is there to stop the download of 1.8 plugins which will break when installed.

See http://nathanw.net/2013/06/13/new-qgis-20-api/ and http://osgeo-org.1560.x6.nabble.com/SIP-API-Update-merged-Attention-plugin-authors-and-nightly-dev-users-td5059106.html#none

Edit: There is no workaround. The plugins just have to be updated.

  • I assumed they worked since they're there in my windows7 qgis 1.9 but they must be there as legacy installs, since I just tried a few & they didn't work. Cheers Nathan - I think part of the reason for my confusion is that I didn't realise that 1.9 shares the same architecture with 2.0, not 1.8 (I assume that's right based on your first line). Thanks again! – dez93_2000 Jul 4 '13 at 15:01
  • Everytime you see or 1.9 think 2.0. There is no 1.9 release we just can't name it 2.0 or else people think it's released. – Nathan W Jul 5 '13 at 1:51
  • Hahaha, well fair enough. You live & learn...! – dez93_2000 Jul 5 '13 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.