1

I'm using QGIS to render some air quality modelling results. I'm having issues with the OpenLayers Plugin whenever I have another vector layer active. The plugin works if it's the only layer in the project, but displays the following error whenever I add another layer. Has anyone else experienced this or know what to do?

An error has occured while executing Python code:
Traceback (most recent call last):
  File "C:/Users//.qgis//python/plugins\openlayers_plugin\openlayers_ovwidget.py", line 250, in __signal_webViewMap_loadFinished
    self.__refreshMapOL()
  File "C:/Users//.qgis//python/plugins\openlayers_plugin\openlayers_ovwidget.py", line 265, in __refreshMapOL
    action = "map.setCenter(new OpenLayers.LonLat(%f, %f));" % self.__getCenterLongLat2OL()
  File "C:/Users//.qgis//python/plugins\openlayers_plugin\openlayers_ovwidget.py", line 275, in __getCenterLongLat2OL
    pntCenter = coodTrans.transform(pntCenter, core.QgsCoordinateTransform.ForwardTransform)
QgsCsException: forward transform of
(11049.424326, 84358.680211)
PROJ.4: +proj=longlat +datum=WGS84 +no_defs +to +proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 +k=1.0 +units=m +nadgrids=@null +wktext  +no_defs
Error: latitude or longitude exceeded limits

Python version:
2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]


QGIS version:
1.8.0-Lisboa Lisboa, 6416f38

Python path: ['C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python', 'C:/Users//.qgis//python', 'C:/Users/hamishh/.qgis//python/plugins', 'C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins', 'C:\\Windows\\system32\\python27.zip', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\DLLs', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\plat-win', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\lib-tk', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\qgis\\bin', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\PIL', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\win32', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode', 'C:\\Users\\\\.qgis\\python\\plugins\\QuickMultiAttributeEdit/forms', '~/.qgis/python', '.', 'C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\qgis\\python\\plugins\\fTools\\tools']

Sorry for the long snippet, thanks for your help.

0

I had the same problem, but this old post OpenLayers Plugin Error: latitude or longitude exceeded limits solved my problem.

Copy and paste:

  1. set the project CRS to EPSG:3857
  2. enable on-the-fly-projection
  3. add the background openlayers layer you want
  4. load other layers

Not the answer you're looking for? Browse other questions tagged or ask your own question.