I just created my account on this forum to find an answer to a stupid (?) problem I can't deal with.
First, let's precise I just (some months ago) learned on my own what GIS was, and gave it a try using QGIS. I'm working on Windows XP. I apologize in advance for my not so good English, and my poor skills (and maybe bad vocabulary) in GIS and kriging.

My problem is:

I need to use kriging to interpolate punctual data from a vector layer (points); this layer is created by me from fieldwork measurements and is in .shp format (try.shp).
I had a look on the internet and saw there were 2 possibilities : use SDA4PP plugin, or Sextante toolbox with SAGA. I wasn't able to have any of them working.
Apparently, SAGA is much easier, thus I would prefer to work with SAGA.

What I have done so far:

I downloaded the last version of QGIS via OSGeo4W (all packages selected).
I downloaded SAGA 2.0.8 from Sourceforge.net (version *_bin_msw_win32), activated it Sextante toolbox, entered the right folder path (which contains spaces) in Sextante configuration.

When I want to perform ordinary kriging, I select the layer, the attribute (which is "id"), ask for a variance grid, target grid is "[0] user defined" (no other choice), I choose an exponentiel variogram model, no block kriging and no logarithmique transformation, and let the default values for the other parameters (especially, grid and variance rasters are saved to temporary files).

Then I click "OK" and get this message error:

Could not layer: C:\DOCUME~1\user\LOCALS~1\Temp\sextante\sagaordinarykriging6fd1782d35df....tif. Check the Sextante log to look for errors.

Here is the error log :

Could not load model watersheds.model

and the algorithm log :

sextante.runalg("saga:ordinarykriging","C:/Documents and Settings/user/Bureau/Kriging/try.shp","id",True,0,1,False,100,False,0,10,100,1,0.1,1,0.5,1000,4,20,1,True,"-55.4887564869,-55.4887477484,-8.61474380806e-07,4.59453003047e-06",None,None)

Any idea of the reason why it doesn't work?

I tried to uninstall-reinstall OSGeo4W using the advanced options. I selected SAGA as a package when reinstalling, but SAGA was not really installed: the tar.gz was downloaded and that's all. I unzipped it, and then I had to enter manually the path, which I chose to be without spaces (C:\OSGeo4W\saga, after having cut-pasted the SAGA unzipped folder at this very place). And ... same as before ... Same error, same behaviour, all the same. Any clue ?


The installation worked well, no errors. I precise I removed all the files concerning SAGA and QGIS before reinstalling (with Add/Remove Programs and Search).

It worked ! I really can't explain why, but it worked. Until now, I was working on a self-made point shapefile, with random points with "id" within the range 0-150. Recently I used a file containing real data from fieldwork, and it worked. I did exactly as for the first file, no clue why it suddenly worked.

One more thing. When using SAGA software, I can choose to select a variogram or not; it seems I can't select a variogram using SAGA via the Sextante toolbox, even if I want to. Why ? Is there a way to select a variogram using SAGA via the Sextante toolbox ? Besides, I guess it's always better to select a variogram (I'm a beginner in kriging).

What do you think ?


If you are going to run SAGA 2.0.8, then you could just install it from the OSGEO4W installer too.

If you select Advanced Install at the beginning of the installer, later on you can Select Packages and saga: SAGA System for Automated Geographic Analyses is under the Desktop category.

With SAGA installed this way, from the SEXTANTE Options window you don't have to even specify the SAGA folder - the plugin will find them automatically if you just place a check beside Activate.

If you want to work with SAGA outside of QGIS, SAGA can be launched directly from the OSGeo4W terminal by using the saga_gui command or scripting with saga_cmd.

Not the answer you're looking for? Browse other questions tagged or ask your own question.