1

I feel this is pretty simple but I haven't had much success searching for an answer and I'm also running out of time so I'm resorting to asking here.

I am trying to export a map with the exact same settings as I always do, but it is choosing not to export the more complicated features such as contours, water and our vegetation inventory while successfully exporting roads, annotation and all the layout components. The problem does not seem to be confined to a certain geometry type. I get the same result no matter the format or settings. Some of the data is on a local server while most of it is from a shared corporate server.

The main culprit is probably the fact that I'm using Data Driven Pages, but I get the same result when I turn them off.

Any ideas? It's not even attempting to export them as it completes in a few seconds while normally I would expect it to take longer. I unfortunately do not have any graphics programs to mess around with.

  • It's just a thought but, as a test, and if you have an Advanced level license available, you may want to consider trying to Dice up one of those complicated features that goes missing. Or if high accuracy is not critical perhaps something from the Generalization toolset may help. – PolyGeo Jul 12 '13 at 2:25
  • 2
    If the export isn't working when you turn off data-driven pages, that would seem to suggest that data-driven pages aren't the culprit. What gets exported and how it gets stacked in the pdf is explained here. Layer ordering is not the same in the export as in the document and transparency will cause a vector layer to be rasterized. Raster layers cause all layers below them to be consolidated into the exported raster layer. This and more are explained in the link. – Llaves Jul 12 '13 at 6:14
0

I solved my problem by adjusting the order of different map layers. One layer of my map didn't show up on the exported map was because it was covered the by another layer, while I didn't notice any difference on ArcMap. I simply send the layer to the front (in the layout view, right click the layer that doesn't show up when exporting, then click Order, choose Bring to Front). You may need to do more adjustment to the order of different layers in order to have all layers displayed properly.

  • Try reducing your DPI by 50 % as a test, I had this issue on some features at 600 dpi but not at 300 – If you do not know- just GIS Mar 12 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.