I am developing a map service, rather basic, with some polygons and labels. Surprisingly, when I deploy this service on the production server, the labels disappear (see here). I have a second local server - for this one, no problem: the labels are well and truly there.

Do you have an idea why my labels vanish that way? Is there some special tuning I should apply on the production server to have them back?

Many thanks for your help.

Precision: It happens with labels with field information. If I use a static text as a labels, the labels are there. The server seems unable to include object fields info within labels.

Additional info: Apparently, this is a well-known problem in ArcGIS server 10.1. See this thread on ArcGIS forum. No solution is known yet...

  • If you make a cache, do you see the labels in the cache? Jul 19 '13 at 8:41
  • Did you try fully qualifying your label expression ... FAOZONES.ICES instead of ICES ? Jul 19 '13 at 19:54
  • Yes, and it do not solve the problem neither.
    – julien
    Jul 22 '13 at 10:39

Your problem may be using the Maplex label engine. I have found that labels set using Maplex do not come through on a service or are highly unpredictable at best.

Try setting the labels the regular, non Maplex way. If you are already using regular labels, try adjusting the scale for label display.

  • 1
    Thanks for your answer. I have no idea which label engine is used... How to check and change it to the regular engine?
    – julien
    Jul 16 '13 at 22:16
  • 1
    @julien Please check following link for Set default labeling properties.(resources.arcgis.com/en/help/main/10.1/index.html#//…) save .mxd and then republish the map service.
    – Sunil
    Jul 17 '13 at 5:33
  • 1
    OK, thanks. I checked, and I am already using the regular engine...
    – julien
    Jul 17 '13 at 14:24
  • @julien How dense are your labels in the map document? I followed the link to your application and it looks like it would not have much detail, but I don't know what is being labeled. If you have a high density, try setting the labels to only display below a certain scale when the user zooms in.
    – Badmagis
    Jul 17 '13 at 21:22
  • The labels contain only 2 letters (country codes).
    – julien
    Jul 18 '13 at 7:06

Would making them an annotation layer solve the issue? Seems like it would be worth a try, although I'm not sure how it robust it would be when you're zooming in and out of the service layer.

  • I prefer not to use annotations to keep the labels scale-dependant. Thanks anyway for the advice.
    – julien
    Jul 18 '13 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.