1

My test server updated today I think it was a PHP update, and since then I can no longer view data in GeoExplorer, only OpenLayers. The GeoExplorer can not see my local server.

Any hints?

Update: Firebug says:

   TypeError: e is undefined
...&&!Ext.isEmpty(f.title)&&(e.set("title",f.title),a.setValue(e.get(d))):c.remove(...

 GeoExplorer.js (line 1535)

Another error from Geoexplorer:

Non-existing source 'local' referenced in layer config.

Further information from the GeoServer log:

org.geoserver.wms.capabilities.GetCapabilitiesTransformer$CapabilitiesTranslator.handleLayer(GetCapabilitiesTransformer.java:899)
    ... 87 more
2013-07-19 13:16:12,458 INFO [geoserver.wms] - Request: getServiceInfo

2013-07-19 13:16:12,459 ERROR [geoserver.ows] - 
org.geoserver.platform.ServiceException: Could not determine geoserver request from http request org.geoserver.platform.AdvancedDispatchFilter$AdvancedDispatchHttpRequest@1965791
  • Unlikely that a PHP update causes this. Looks like WMS GetCapabilities is broken. Try to open localhost:8080/geoserver/… in a browser and scan the response for error messages. – ahocevar Jul 17 '13 at 12:13
  • @ahocevar It only seems to do this occasionally, where the local server wont load, It happened a few days back, I ended up making a new test server and everything worked. I have hardly touched geoserver all I have done is linked to my postGIS, and created a style. Turned it off yesterday, and today I get the error I posted above. – Tom Jul 19 '13 at 12:04
1

This is down to a faulty change in SLD, even though the style worked, when I restarted the server this is when the geoexplorer issues arise. Solution, delete the style, and replace with the default SLD cookbook style.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.