2

I have a Landsat footprint polygon shapefile that I simply want to create a 6 x 6 fishnet on. I thought this would be simple, but every time I run the tool I get a fishnet output that extends longer than the original footprint and is shorter in height. I think the problem may stem from the fact that the footprint is slanted and the y-axis may be a different angle than the x-axis.

I used Feature Vertices to Points and then Add XY Coordinates to get the exact coordinates of the footprint polygon's corners. Then within the Fishnet tool, I used the footprint's extent as the 'Template Extent', the bottom left corner as the 'Origin Coordinate', the top left corner as the 'Y-Axis Coordinate', and the top right corner as the 'Opposite corner of Fishnet.'

Coordinate system is WGS_1984_UTM_Zone_18S.

Any ideas for how I can fix this and generate a properly placed fishnet?

Here's the strange looking fishnet output:

Fishnet

And here are the parameters I passed into the fishnet tool, along with the proper corner coordinates in the top left of the image (Point_X and Point_Y):

Fishnet tool screenshot

closed as unclear what you're asking by PolyGeo Jul 19 '16 at 9:31

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • An easier way to get the extents of the polygon would be to open properties -> source. Have you tried flipping the coordinates around to see if maybe x was inputted into y and vice versa? – Paul Jul 16 '13 at 14:52
  • Maybe theres a coordinate system error. Try checking whether the fishnet feature class has the same CRS as your landsat data and the same as the whole data frame. – til_b Jul 16 '13 at 14:56
  • Thanks for the responses. The Coordinate Systems all match up. I'll try switching some of the XY coordinates and see if that's the fix. – rdg918 Jul 16 '13 at 16:01
  • Can you use Copy Python Snippet in your Geoprocessing | Results window to show us what parameters you passed to CreateFishnet? Are you expecting square cells in your fishnet and/or what size should they be? – PolyGeo Jul 16 '13 at 20:12
  • 1
    Does the fishnet layer have a defined coordinate system? And if not, could the data frame not be in the same one? – mkennedy Jul 16 '13 at 20:46
0

As a comment you provided a line of ArcPy code that I just tested using:

import arcpy

arcpy.CreateFishnet_management("C:/Temp/test.shp","223122.902847 4244274.58422","266744.967575 4410255.40647","0","0","6","6","447614.673105 4372719.14612","LABELS","wrs_dec_va_proj15033","POLYLINE")

This reported an error:

Traceback (most recent call last):
  File "C:\Temp\test.py", line 4, in <module>
    arcpy.CreateFishnet_management("C:/Temp/test.shp","223122.902847 4244274.58422","266744.967575 4410255.40647","0","0","6","6","447614.673105 4372719.14612","LABELS","wrs_dec_va_proj15033","POLYLINE")
  File "C:\Program Files (x86)\ArcGIS\Desktop10.4\ArcPy\arcpy\management.py", line 15397, in CreateFishnet
    raise e
ExecuteError: ERROR 000622: Failed to execute (Create Fishnet). Parameters are not valid.
ERROR 000628: Cannot set input into parameter template.

I am reluctant to investigate this error because the code snippet does not seem to match the parameters that you have used in the picture of your tool dialog.

Not the answer you're looking for? Browse other questions tagged or ask your own question.