Does anyone know how to use a .SHP in Trimble Sketch-Up?

I have tried exporting to KML and CAD from QGIS, but the KML file doesn't read in Sketch-Up.


@mapperz provided this answer:


This is a great plugin and works like a charm. It is, however, very sensitive to coordinate systems, so I would suggest:

  • make sure your SHP is in LAT/LON (WGS84)
  • start a new sketchup document in 'metres'.

Worked for me! Thank you again, @Mapperz!


This plugin stopped working beyond Sketch-up 7, and the project's Github page hasn't been updated in some time, and does not have 'issue tracking' enabled (weird.)

However, I was able to download a version of Google SketchUp 7 from this shifty website, and the plugin seems to be working as described above.

  • This is a great plugin. Have you been able to use the extrude by height field option? I have tried it on a number of different files and the drop down list is always empty, even when I have attribute fields. – Ryan Garnett Jul 19 '13 at 22:52
  • @RyanGarnett no i haven't...only looking at 2D parcels right now... – DPSSpatial Jul 21 '13 at 15:20

I have been developing a personal open source project. I have placed it on GitHub. It works for SketchUp v14 and v15. Please make sure coordinates are in WGS 1984 Geographic Coordinates. You will also need to geo-locate your model. Right now it only supports points and polylines, but other types will be coming soon.

It is in beta, and I will place it in the extension warehouse once it has a good testing.



I haven't tested it yet but I was looking for this and found a plugin - vaguely titled spirix_shapefile_importer that imports shapefiles into newer versions of sketchup including sketchup 2016 (plugin Ruby).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.