1

I'm not a GIS expert at all, but I've been asked to add a KML layer to an Openlayers map which probably needs some tweaks and that's where I get confused.

Let say I have an Openlayers map with the following projection:

Projection: EPSG:900913
DisplayProjection: EPSG:4326

The KML file that I have contains Geo-coordinates like these:

44.22912497884251,41.93612718554421,0 44.22898876056436,41.93614742383577,0

When I'm trying to show this data on the map, I got nothing, however another KML file shows perfectly fine. It contains some test data like these:

4651136.141979168, 5265323.674468365 4997243.006006268, 5205611.478023042

As far as I can see, there is a projection issue here. What I don't get is the first data looks more correct according to my map projection settings, but it doesn't show up any where or at least I can't find it any where. The second file seems to have different projection, maybe EPSG:3857 (a.k.a. Spherical Mercator), but it will go straight to the map.

We have also ArcGIS installed in one our computers, however as I said, I'm not a GIS expert. If somebody could guide me either through the exporting KML file in ArcGIS (I have the original shape files as well), or the Openlayers settings to show up the KML file, I'd really appreciate that.

  • If you decide to pursue the ArcGIS for Desktop option there is a help page on Creating KML that you should start by reviewing. – PolyGeo Jul 23 '13 at 22:07
1

epsg:3857 and epsg:900913 are the same projections, and they uses a lat/long coordinate system and treats the earth as a sphere. epsg:4326 is ddifferent projections, and it use x/y axis coordinate system. So, you need to transform your coordinates in appropriate projection, you can do that in arcgis, using PROJECT tool in Data Management Tools\projections and transformations\ feature toolbox: http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//00170000007m000000

  • thanks Milos, but can you please specify what is the appropriate projection in this case? Should I export it as EPSG:4326? thanks. – Mahdi Jul 23 '13 at 13:12
  • I think you should reproject in wgs84. – Milos Jul 23 '13 at 13:32
  • thanks for the help, finally solve that, it was wgs84 as you mentioned :) – Mahdi Jul 24 '13 at 6:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.