9

I have highways labeled with the standard shield and route number on it. For my main data frame the labels come up correctly. I also have 4 inset maps where only the number will show up, not the shield when exporting to a file (any type).

Here are some things that I tried that did not work:

  • Exporting the labels to annotation
  • Creating replacement graphics (in each inset's data frame view)
  • For each of the above, using .png background instead of .emf

The only solution that seems to work is creating graphics as part of the document itself and overlaying those on top of the inset. This is very bad practise however and the graphics will not pan with the inset.

Just to clarify, the shields (text background) shows up in the layout screen when editing the map but not in the exported product after exporting the map to a .pdf or other extension.

The version of ArcGIS being used is 10.1 SP1. I cannot upgrade or change the installation.

Suggestions tried:

  • Deleting the main dataframe, then exporting - same result
  • Moving the inset dataframe to a new document

UPDATE:

It appears that ArcGIS will hide (or not draw) background symbols that are smaller than a certain size compared to the map (% or ratio). When I made the print size smaller (it was originally 34x40 inches) or the symbols larger, the shields showed up.

Does anyone know how to change this option on ArcGIS and possibly show all symbols regardless of size?

Following comment suggestions, the links provided in this forum post did not help.

However, following the last link showed that the exported EMF file was not correct, signaling that "the problem exists within ArcMap, usually in converting the elements drawn in the map to the EMF format."

  • but they do show up in the inset before printing/export? – Brad Nesom Jul 23 '13 at 14:53
  • 1
    If you delete the main mapframe and then do an export, do any of the remaining mapframes have shields? – Kirk Kuykendall Jul 23 '13 at 15:21
  • 1
    Have you tested this on a machine running ArcGIS for 10.1 SP1 (who knows, it may just work there)? Alternatively, you do not mention which Service Pack to 10.0 you are using, an upgrade to SP5 may also be valuable. – PolyGeo Jul 25 '13 at 3:13
  • 1
    Have you tried copying just one of the data frames from which the shields are missing into a new Blank Map? If the problem is still there then testing efforts can switch to a simpler and more likely to be reproducible example. Also, as you respond to comments be sure to keep editing and thus improving your question so that new potential answerers do not have to read all the comments to understand the current status of your question. – PolyGeo Jul 26 '13 at 22:36
  • 1
    forums.arcgis.com/threads/… .... perhaps? – Moggy Jul 29 '13 at 18:54
2

Have you tried adding an mask (invisible or no color) with a halo size = 1, and then under Advanced Text -> Text Background -> Properties, select Scale marker to fit text. This way if you want more shield to appear around the text, you just increase the mask size. Hope this helps.

  • Due to a change in responsibilities, I no longer have access to that file and wasn't able to reproduce the issue. If I get a chance to try it out I will let you know. – Eyrofire Jan 20 '14 at 14:23
1

I meet the same problem in ArcMap 10.2:

like this: enter image description here

For me it seems a "printer dpi" problem I set ArcMap Export Map's dpi with 800 dpi but my printer only support to 600 dpi. After I set ArcMap Export Map's dpi with 600 ,the problem solved.

Reference: http://support.esri.com/en/knowledgebase/techarticles/detail/30753

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.