9

I have highways labeled with the standard shield and route number on it. For my main data frame the labels come up correctly. I also have 4 inset maps where only the number will show up, not the shield when exporting to a file (any type).

Here are some things that I tried that did not work:

  • Exporting the labels to annotation
  • Creating replacement graphics (in each inset's data frame view)
  • For each of the above, using .png background instead of .emf

The only solution that seems to work is creating graphics as part of the document itself and overlaying those on top of the inset. This is very bad practise however and the graphics will not pan with the inset.

Just to clarify, the shields (text background) shows up in the layout screen when editing the map but not in the exported product after exporting the map to a .pdf or other extension.

The version of ArcGIS being used is 10.1 SP1. I cannot upgrade or change the installation.

Suggestions tried:

  • Deleting the main dataframe, then exporting - same result
  • Moving the inset dataframe to a new document

It appears that ArcMap will hide (or not draw) background symbols that are smaller than a certain size compared to the map (% or ratio). When I made the print size smaller (it was originally 34x40 inches) or the symbols larger, the shields showed up.

Does anyone know how to change this option on ArcMap and possibly show all symbols regardless of size?

Following comment suggestions, the links provided in this forum post did not help.

However, following the last link showed that the exported EMF file was not correct, signaling that "the problem exists within ArcMap, usually in converting the elements drawn in the map to the EMF format."

0

2 Answers 2

2

Try adding a mask (invisible or no color) with a halo size = 1, and then under Advanced Text -> Text Background -> Properties, select Scale marker to fit text.

This way if you want more shield to appear around the text, you just increase the mask size.

1
  • Due to a change in responsibilities, I no longer have access to that file and wasn't able to reproduce the issue. If I get a chance to try it out I will let you know.
    – Eyrofire
    Jan 20, 2014 at 14:23
1

I meet the same problem in ArcMap 10.2:

like this: enter image description here

For me it seems a "printer dpi" problem I set ArcMap Export Map's dpi with 800 dpi but my printer only support to 600 dpi. After I set ArcMap Export Map's dpi with 600 ,the problem solved.

Reference: http://support.esri.com/en/knowledgebase/techarticles/detail/30753

Not the answer you're looking for? Browse other questions tagged or ask your own question.