We've installed OpenGeo Suite 3.1 on Ubuntu 12.04 LTS and everything works fine.

When trying to set up the OpenGeo Client SDK 3.0.2 (following http://suite.opengeo.org/opengeo-docs/apps/clientsdk.html), however, the OpenGeo Suite doesn't work anymore. After inserting the SDK in PATH and adding ANT_HOME and JAVA_HOME in /etc/environment, tomcat6 starts up, but doesn't serve anything in the browser anymore.

The severe error in the log looks as follows:

24 Jul 15:35:24 WARN [config.CustomEditorConfigurer] - Passing PropertyEditor instances into CustomEditorConfigurer is deprecated: use PropertyEditorRegistrars or PropertyEditor class names instead. Offending key [org.geotools.util.Version; offending editor instance: org.geoserver.platform.util.VersionPropertyEditor@3f705316

24.07.2013 15:35:24 org.geoserver.platform.GeoServerExtensions checkContext
SCHWERWIEGEND: Extension lookup occured, but ApplicationContext is unset.

24 Jul 15:35:24 ERROR [geoserver.global] -
- GEOSERVER_DATA_DIR: /usr/share/opengeo-suite-data/geoserver_data

Any help would be greatly appreciated. Are there conflicts between the versions? A new SDK doesn't seem to exist yet.

EDIT: The error from the log doesn't seem to have to do anything with our problem, since it is also logged in another working geoserver environment.

  • OK we solved our issue. The problem was that the server's IP was kicked out of the iptables upon reboot after modifying the PATH. In addition we didn't put ./ in front of "suite-sdk create path/to/myapp" when running the script in bin, so the command wasn't found. Still learning on Linux... thanks for the quick reaction!
    – tobik
    Commented Jul 25, 2013 at 14:02
  • Ok, but you should definitely not set JAVA_HOME.
    – user20472
    Commented Jul 26, 2013 at 10:25

1 Answer 1


On Linux, you only need to set the PATH for the suite-sdk binary. Do not set JAVA_HOME and ANT_HOME, these are taking care of already.

  • Thanks for the quick response. We had tried this before, but if we don't set ANT_HOME we cannot run "suite-sdk create path/to/myapp", because the command is not found.
    – tobik
    Commented Jul 25, 2013 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.