I installed GeoServer via OpenGeo Suite, and still working on it.

I created a "Layer Group" and add layers from local PostGIS. I tried to preview it from "Layer Preview" and show perfectly through the "OpenLayers" option, but unable to show in "GeoExplorer".

I got the javascript warning message says: "Could not create layer record for layer 'testgroup'. Check if the layer is found in the WMS GetCapabilities response." on GeoExplorer.js:1441

To view the source code shows like:

1441: {name:"fixed",type:"boolean"},{name:"selected",type:"boolean"},{name:"restUrl",type:"string"},{name:"infoFormat",type:"string"},{name:"getFeatureInfo"}];c.fields.each(function(a){i.push(a)});b=new (GeoExt.data.LayerRecord.create(i))(h,b.id);b.json=a}else window.console&&0<this.store.getCount()&&void 0!==a.name&&console.warn("Could not create layer record for layer '"+a.name+"'. Check if the layer is found in the WMS GetCapabilities response.");return b},getProjection:function(a){var b=this.getMapProjection(),
    "Could not create layer record for layer 'testgroup'. Check if the layer is found in the WMS GetCapabilities response."
1442: c=b,a=a.get("srs");if(!a[b.getCode()]){var c=null,d,e;for(e in a)if((d=new OpenLayers.Projection(e)).equals(b)){c=d;break}}return c},initDescribeLayerStore:function(){var a=this.store.reader.raw;this.lazy&&(a={capability:{request:{describelayer:{href:this.url}}},version:this.version||"1.1.1"});var b=a.capability.request.describelayer;if(b)a=a.version,1.1<parseFloat(a)&&(a="1.1.1"),a={SERVICE:"WMS",VERSION:a,REQUEST:"DescribeLayer"},this.describeLayerStore=new GeoExt.data.WMSDescribeLayerStore({url:this.trimUrl(b.href,

I am sure that I can preview them separately in GeoExplore from "Layer Preview" page.

It seems everything goes well when I checked it from http://localhost:8080/geoserver/wms?SERVICE=WMS&REQUEST=GetCapabilities, without any error massages or exceptions shown, and the layer group description show at the bottom of the page.

Does anyone run into the same problem?


I found that I missed a javascript error massage when I view the REQUEST=GetCapabilities page.

It says: "Uncaught TypeError: Cannot set property 'boxSizing' of null" on ContentVeil.js:11

To view the source code shows like:

11: veil.style.boxSizing = "border-box";
    "Uncaught TypeError: Cannot set property 'boxSizing' of null"
12: veil.style.borderStyle = "solid";

I am wondering where the error comes from.


I cannot load the "field list" when editting limit condition in style's rules in GeoExplorer.

  • I just came across this problem, system was working fine last week, all I did was create styles, and some DB views within the DB software rather than geoserver. Come back to it a week later and only openlayers shows my layers from postGIS. Geoexplorer only shows the Medford stuff from the local aerver not my PostGIS tables
    – Tom
    Commented Sep 10, 2013 at 14:52
  • I have no idea how but it has fixed itself..... I did delete my styles, however they were all validated. Tried a few browsers, I was just about to compare the URL from a Medford layer to my PostGIS layer and it loaded. I have had issues with styles with images before...
    – Tom
    Commented Sep 10, 2013 at 14:59

2 Answers 2


I've solved the problem, but still don't know how is everything working.

I discover there is a bug in sometimes that request to http://localhost:8080/geoserver/wms?

If without the request parameter &service=wms, it will go wrong and response with error message says: ServiceException code="MissingParameterValue" in firebug Network page.

The same problem happened when I request to WFS service, if I add &service=wms in the end of URL, everything is just going fine.

I guess there should be a default value that I never notice or set up, broken by my unintentional mistake.

And here is my solutions:

  • Go to the GeoServer "Service" page, choose WMS or WFS service

  • enable the both Service Metadata options, especially Strict CITE compliance

  • Submit, then change it back to previous setting.

At this moment, it should get the right response even without the parameter &service=wms in URL.

I guess the optionStrict CITE compliance must overwrite something and recover it at the same time, but I'm not pretty sure about that.


I know this is an old thread. But I recently had the pleasure of encountering the same problem! I tried the provided answer but it did not solve my problem.

I was actually just not focusing. When I created the layers from SQl I used the attribute/metadata table instead of the tables that contained the geometry/features.

Using the right data source fixed my problem. Maybe this will help someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.