3

Apologies in advance for the potential for this to be a duplicate question, I've had a good look, and I can't see a solution that I understand well enough to help me.

I have my project CRS set to a local UTM projection, however when I add a map from OpenLayers the project CRS changes to EPSG:3857. When I add a grid in Composer, I need to display the longs and lats of the local UTM, not the OpenLayers coordinate reference system.

I understand that I need to have the project CRS the same as the OpenLayers CRS, but is there a way I can:

  1. save and reproject the section of the OpenLayers raster into my local UTM, so it still lines up with my vector layers or
  2. display the appropriate coordinates on the grid, despite the project CRS being in EPSG:3857.

This is an issue that I have with many of my maps, where I use aerial imagery for my base layers, but need to display local coordinates in my final map.

Will there be an easy solution to this in QGIS 2.0?

3

You can always use File -> Save as Image... for the Openlayers background layer, change the CRS to UTM and add the Image as Raster. Unfortunately, your raster looks weired if you zoom in further.

You can also create a vector grid with Vector -> Resarch Tools - Vector grid of your favourite UTM zone, and add that grid with labelling to the original Openlayers background in project CRS EPSG:3857.

  • Thanks Andre, I saw your suggestion in response to another query. the "save as image" was my least preferred option, only because it doesn't look great, but I think I'll have to go with it. When I tried the 'Research tools - Vector grid' it crashed my session. – Staci Timms Jul 29 '13 at 3:25
  • 1
    The vector grid has an inconvenient preset for grid spacing. If you have metres as units, it should be 1000 or more, not 0.001. – AndreJ Jul 29 '13 at 3:54
  • 1
    It might be helpful to use the Densify function on the vector grid if the grid is expected to be curved in the project CRS. – AndreJ Sep 10 '13 at 5:37
0

When you add an Open Layers map to your project, CRS is changed to EPSG:3857. Go to Project properties and change back the CRS to your local UTM projection (and don't forget to enable on-the-fly projection).

Now back in your composer. If you refresh the map, you'll see that coordinates kept in the extents were those in EPSG:3857 CRS, so your map should be very far away from your desired extents. Just click "set to map canvas extent" or re-enter manually X and Y limits.

Then your grid should be in local UTM units.

  • Thanks, I tried that and it works for the grid labels, but the accuracy of the vector layers and the background map seems to be affected (shifts about 20m NW) despite the "Enable 'on the fly' CRS projection" option being active. Totally frustrating, as it's such a simple thing, but so tricky to get an accurate, well labelled map. I have my fingers crossed that there will be an easy solution in QGIS 2.0, can't wait for it to be released. – Staci Timms Jul 29 '13 at 2:48
  • You didn't mention your exact area, but datum shift grids can correct some reprojection. See Proj.4 page – tqhien Aug 2 '13 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.