I am attempting to join a spreadsheet containing all the CIA Factbook Country Comparison Data (many columns) to the existing Natural Earth world countries shapefile. I followd the tutorial here, but a couple of things occurred:

1) Several of bits of data were changed to -2147483648

2) The imported field lengths all show as "0" in the properties.

I am not trained in GIS and I have never worked with databases. I am simply trying to combine this data and shapefile, so that my students will be able to graphically manipulate and analyze the information in a new Global Studies course.

I've tried taking the spreadsheet (from Excel) and putting it through Access and then exporting to a dbf file. I have set all the field lengths to 100 (and even tried 50), but I get a "field will not fit in record" error. I even tried truncating the column headings to 10 (thinking that might have been the problem, based on internet searches), but it didn't help.

As Per Comment:

Here is a link to a version of the spreadsheet with truncated headings.

Here is a picture of the corrupt data.
https:// docs . google . com/file/d/0BzHj6AzbbxcINy1jTGRPTDh1bFU/edit?usp=sharing

  • Can you show a sample of the problematic CIA Factbook spreadsheet? Have you tried loading the CSV using the Add delimited Text layer tool? – underdark Jul 27 '13 at 15:53
  • I added a link to a version of the spreadsheet with the truncated headings as well as a link (remove spaces) to a picture of the data corrupted. I read someone about it the corrupted data being related to the field length. I didn't use the "Add delimited Text layer tool", since I was following the tutorial listed above. Again, I am not trained in GIS and I am learning the basics to be able to help my students evaluation/interpret/manipulate data, not actually create detailed GIS-based maps from scratch. There are 8th graders, hehehe. :-) – Kazimierz Jul 27 '13 at 16:45
  • It's well possible that the values are too large. You might want to try to devide by 1 million to create smaller values to work with. – underdark Jul 27 '13 at 18:16
  • So, for some reason, QGIS doesn't like to import numbers that are in the billions? With Economic data, there is going to be a lot of them. I will have to find a way to batch edit it then. – Kazimierz Jul 27 '13 at 18:32
  • I've had similar issues with Shapefiles that contained very large integer IDs. It seems to be an issue of the underlying OGR driver. That's why I asked if you tried Add delimited text layer because it is independent of OGR. – underdark Jul 27 '13 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.