I've started getting an error on Ubuntu when trying to upgrade packages: "Not all updates can be installed Run a partial upgrade, to install as many upgrades as possible"

When I run a partial upgrade, I get this: "Could not calculate the upgrade An unresolvable problem occurred while calculating the upgrade: The package 'postgresql-9.1-postgis' is marked for removal but it is in the removal blacklist. This can be caused by: * Upgrading to a pre-release version of Ubuntu * Running the current pre-release version of Ubuntu * Unofficial software packages not provided by Ubuntu

This is most likely a transient problem, please try again later."

I have PostGres 9.1.9 and PostGIS 1.5.3.

Sounds similar to this problem: https://gis.stackexchange.com/questions/67143/postgresql-9-1-postgis-2-0-ubuntu-12-04-installation-problem



1 Answer 1


Seemed to be the Ubuntu GUI upgrade that was the problem. Solved it by: 1: sudo apt-get update 2: sudo apt-get upgrade

There was an error fetching the ubuntu-gis-unstable ppa tho'


  • Yes if you're using ubuntugis-unstable the current version of Postgis is 2.0. However it won't force you to upgrade to that unless you specifically ask it to because such an upgrade requires upgrades to several dependencies. Jul 29, 2013 at 23:37
  • Ok, thanks wildintellect, I might like to upgrade - are the steps light and simple?
    – minisaurus
    Jul 30, 2013 at 17:59
  • Depends on how complicated your database is. Worst case scenario you have to dump and load your databases. Note postgis 1.5 and 2.0 can exist on the same system. Aug 14, 2013 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.