How do I install the r.inund.fluv script in GRASS? https://svn.osgeo.org/grass/grass-addons/grass6/raster/r.inund.fluv/

  • Have you tried following the instructions in the included README.txt file? What are you stuck on?
    – scw
    Mar 3, 2011 at 7:22
  • I already installed the gfortran. I used GRASS to run the script: g.extension r.inund.fluv but it failed and produced this error: (Thu Mar 03 23:22:54 2011) g.extension r.inund.fluv which: svn: unknown command ERROR: svn client required. Please install Subversion first. (Thu Mar 03 23:22:55 2011) Command finished (1 sec) I do not know what caused the error. I do not know what is the subversion that the error was referring to.
    – teamAngat
    Mar 3, 2011 at 15:28
  • Hei guys, first of all thanks a lot for creating such a great software like GRASS GIS. I recently installed GRASS GIS using OSGeo4W installer on a 64 bits machine running windows 7. Sofar so good. Everything works perfectly in windows 7 OS. However, today i hit the wall when I tried to install r.inund.fluv by using different methods: a) within the grass command line using g.extension r.inund.fluv [--here, I got the error mentioned above by scw-user--] b) I downloaded the r.inund.fluv [files] and compiled them using fortran compiler [GCC 4.6.4]. I followed the 4 steps described by the a Oct 22, 2013 at 12:24
  • @geoendemics as it is not an answer you are describing what you have done, it needs to be a potential solution. Rather I did this, you need you describe do this to fix it.
    – Mapperz
    Oct 25, 2013 at 13:52
  • I am trying to use r.inund.fluv and I am having the same problem that you had. Please could you share with me some steps on how to compile it. Thanks alot.
    – EauDyssee
    Jul 1, 2015 at 22:53

2 Answers 2


In order to use g.extension, you'll need to install Subversion, a version control system. Apache provides binaries for most platforms.

  • Thanks. I already installed the subversion. There are still errors. I think the errors were caused by wrong directories. Here is the results after running the script: (Fri Mar 04 10:15:25 2011) g.extension r.inund.fluv Fetching <r.inund.fluv> from GRASS-Addons SVN (be patient)... A r.inund.fluv\r.inund.fluv_62 A r.inund.fluv\correction_from_path.f90 A r.inund.fluv\clean_inundation.f90 A r.inund.fluv\r.inund.fluv A r.inund.fluv\find_main_channel.f90
    – teamAngat
    Mar 4, 2011 at 2:21
  • A r.inund.fluv\README.txt A r.inund.fluv\r.inund.fluv.html A r.inund.fluv\Makefile A r.inund.fluv\2d_path.f90 Checked out revision 45545. Compiling <r.inund.fluv>... Makefile:4: C:/Program: No such file or directory Makefile:4: Files/GRASS-64/include/Make/Script.make: No such file or directory Makefile:5: C:/Program: No such file or directory Makefile:5: Files/GRASS-64/include/Make/Module.make: No such file or directory make: *** No rule to make target Files/GRASS-64/include/Make/Module.make'. Stop.`
    – teamAngat
    Mar 4, 2011 at 2:22
  • ERROR: Compilation failed, sorry. Please check above error messages. rm: cannot remove directory C:/Users/Rhen/Documents/GIS DataBase/teamAngat/PERMANENT/.tmp/6744.0/r.inund.fluv': Permission denied (Fri Mar 04 10:15:41 2011) Command finished (16 sec)`
    – teamAngat
    Mar 4, 2011 at 2:22
  • 1
    From your last comments I understand that you work on Windows. To my knowledge g.extension is not yet function on Windows. But packaging of all extensions is on the way. Best asked as enhancement ticket in the GRASS bugtracker.
    – markusN
    Mar 4, 2011 at 19:12
  • Thanks. I already resolved it by compiling the codes in Fortran.
    – teamAngat
    Mar 13, 2011 at 16:43

In a GRASS session, if a compiler is available on the system, run

g.extension r.inund.fluv

This GRASS module is one of the very few modules written in Fortran, so you need a Fortran compiler environment to be installed on the system.

  • Fortan is already installed in my computer. I tried running the script g.extension r.inund.fluv but it produced an error as what I have said in the comment above. How do I resolve it?
    – teamAngat
    Mar 3, 2011 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.