I have a small application used to check and generate network, created with the help of the following tutorial: http://help.arcgis.com/en/sdk/10.0/a...00000w7000000/

It worked just fine with ArcGIS 10, but since I had to upgrade to 10.1, the application fails on this line:

INetworkDataset networkDataset = (INetworkDataset)datasetContainer2.CreateDataset(deDataset);

The error code is "System.Runtime.InteropServices.COMException was unhandled Message=Exception from HRESULT: 0x80042262", which really isn't helpful. Is there something new I could have missed, or some help on what could cause such an error ?

  • 1
    Are you calling ESRI.ArcGIS.RuntimeManager.Bind as shown in the closest facility solver sample? Jul 31, 2013 at 13:12
  • Yes, I have used this method in several small applications and the others still work with 10.1.
    – Arnaud31
    Jul 31, 2013 at 15:53

1 Answer 1


The issue was finally solved and it had nothing to do with this particular function, the origin was a database insertion that failed without error message. As a result, the database used with our solver wasn't complete like expected and the CreateDataset failed.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.