There is probably already a post for my problem, but after long searching, I could not find a solution for my issue.

I am working with QGIS und I am using the following projection/datum: MGI / Austria GK East (EPSG:31256) (+proj=tmerc +lat_0=0 +lon_0=16.33333333333333 +k=1 +x_0=0 +y_0=-5000000 +ellps=bessel +towgs84=577.326,90.129,463.919,5.137,1.474,5.297,2.4232 +units=m +no_defs)

I just want to add a layer form the openlayers plugin. For example Google satelite. the Google satelite uses the following projection/Datum: WGS 84 / Pseudo Mercator (EPSG:3857) (+proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 +k=1.0 +units=m +nadgrids=@null +wktext +no_defs).

The Problem that I am facing with, is that I can not get the Google layer in the same projection with my other layers (EPSG:31256)! They are not overlapping correct!

Is there a way to do this?

  • 2
    google will always be in 3857 you can't change this. Just reproject your data to match.
    – Ian Turton
    Aug 1, 2013 at 7:14

3 Answers 3


The only possible solution is to take a screen shot of the Google imagery of your area of interest in CRS:3857 with File -> Save as image, delete the Openlayers layer, change CRS to the one you want, and add the image(s) as raster.

This makes zooming in look a bit weired, but you can take several images in a higher zoom level, and stitch them together.

  • 1
    doesn't that violate the Google ToS?
    – Ian Turton
    Aug 1, 2013 at 9:22
  • Unless you publish it, nobody will notice it.
    – AndreJ
    Aug 1, 2013 at 9:36
  • 1
    @iant: As per my understanding, By Google's TOS, you can't store the tiles, but you can take and use screenshots. Whether you can digitize off those screenshots is a different matter. Aug 1, 2013 at 10:02
  • Thanks a lot for your fast help!! sad to hear that it's not posible to reproject in a proper way. the qgis guys should work on that ;) !!! Aug 2, 2013 at 6:26
  • 1
    It's not that easy. The Google picture comes as 256x256 px tiles. If you reproject them, you get black borders at every tile. Only solution is to load all tiles, stitch them together, and reproject the whole before displaying. But that would take to long if you just pan across the map. A WMS service would react better, but Google does not offer that.
    – AndreJ
    Aug 2, 2013 at 7:11

To increase precision, some CRS use a datum shift grid. That's the case for IGNF for instance, with a ntf_r93.gsb file to add to the prj.4 call (+nadgrids=ntf_r93.gsb,...) .

I see that MGI has a shift grid : BEV grid

I hope that'll help.

  • No, that grid is only for height data. You have to look for bev.gv.at/portal/…. But thats probably not what the asker wanted.
    – AndreJ
    Aug 2, 2013 at 14:23

When working with Google, OpenStreetmap and other maps which use the spherical mercator, you should work in EPSG:3857, i.e. you should project(geotransform) your layer to 3857 projection system.

Qgis will perform this automatically if you enable it in Settings->Options->Coordinate reference System(CRS)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.