this is my first question on Stackexchange. I use a GPS to capture data in .dxf, manipulate it in a CAD program that I know how to use, then the dxf2shp converter (I think Python is mentioned) to let me generate .shp files for the end user. Every time I've done this recently I've got a meesage from QGIS that it has stopped working and will close. I've tried re-installing QGIS (1.8.0), but still have the same message. Am I doing something wrong or is this a known problem. Please note I'm not really computer literate, so if you could avoid assuming I know what a technical term means, i'd be grateful.

2 Answers 2


You can try loading the dxf into QGIS with Add vector layer, and then rightclick on the layer and Save As ... into shapefile format.

That way you might get better error messages, and a visual control on the data.

For the shapefile, you must decide what coordinate refrenece system you are using (lat/long degrees or metres).

  • Adding as a vector layer worked, but it wouldn't save as a shapefile (OGR error failed to open shapefile). I guess that's a different issue?
    – user20827
    Aug 7, 2013 at 9:43
  • Have you selected a suitable folder with Browse ...? Maybe it wants to save in the program folder, and you have not the rights for it.
    – AndreJ
    Aug 7, 2013 at 10:01
  • Check the attribute table of the DXF layer. Shapefiles have limits on field lengths. Check if it will save to something more general, like GeoJSON or GML.
    – scruss
    Aug 7, 2013 at 13:59
  • The problem recurred to version 2.4.0 QGIS when used the Dxf2Shp convert plugin, that comes with the software. Following the instructions of the first response in this forum, that is, adding the DXF file as a vector layer and then clicking on this bed with the right mouse button and choosing Save As, it worked perfectly. O problema era recorrente para a versão 2.4.0 do QGIS, quando usava o plugin Dxf2Shp converter, que vem junto com o programa. Seguindo as instruções da primeira resposta neste fórum, isto é, adicionando o arquivo DXF, como uma camada vetorial e depois clicando nessa cama com o
    – user39457
    Oct 20, 2014 at 16:53

I am just guessing that you may have a problem with your processor speed. I have had issues in the past with this.

In the past, i have added dxf, typically of plans etc., to the viewer. However i have found it more useful to use the tool in Vector - Data Management Tool - Split Vector Layer. This allows you to split your dxf layer by its internal layers into individual shapefiles for each internal layer.

this should solve your problem.

  • I had wondered about processor speed being the problem. Adding then splitting the vector layer is a good solution, so many thanks
    – user20827
    Aug 8, 2013 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.