I am selecting two points from a table and then doing a points to line function. I was originally getting this error because they were multipoints with multiple locations. I ran Multipart to Single Part on that layer and now am getting the same error on only a select few points but there are no multiples.

What else can cause this error? Thanks!

temporarytodraw holds 2 points and that's the result I get. I'm sorry I don't have much more to post than this. It selects points that match certain criteria and places them in the temporarytodraw but there is an if statement check to kick out any records that match less than 2 or more than 2.

arcpy.PointsToLine_management("temporarytodraw", "offset_line_thing", "", "", "NO_CLOSE")
  • This is the famous ESRI 999999 error, which basically says "Something bad happened". Could you post some code to reproduce this ? – Oyvind Aug 13 '13 at 14:01
  • I had the same error but with a different tool and found that the name of the projection (with identical parameter) was different. Reprojecting the input solved the problem. – EikeMike Jan 13 '17 at 12:28

The extended error information, "Coordinates or measures are out of bounds", points towards a spatial reference / coordinate reference system problem. Are all points in the table using the same coordinate reference system (CRS)? What, if any, CRS does the output feature class have and is the same as the input points?

In ArcGIS, each CRS has default xy/z/m extents. As an example, if the input table's points were in a projected CRS, but the GP environment was using a geographic CRS, there could be input points with negative values that are outside the xy extents of the geographic CRS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.