2

Over the last two days I've tried to set up and to use a postgreSQL database to use WFS and Feature Access. I've also started a thread in the esri forums, but I hope that I can reach a wider audience here. Some basic information, what I've done

  • ArcGIS 10.2 installed on Windows Server 2012
  • PostgreSQL 9.2.2 64Bit is installed on the same server as well as PostGIS 2.0
  • I've edited the pg_hba.conf to have remote access.
  • I've copied the necessary 32Bit client files (libeay32.dll, libiconv-2.dll, libintl-8.dll, libpq.dll, ssleay32.dll) (which I've downloaded from the Customer Portal-> Package: PostgreSQL_Client_Libraries_for_Windows_101_130031.exe) into the \bin-Directory of my ArcGIS Desktop 10.2 installation.
  • I've copied the necessary 64Bit client files (libeay32.dll, libintl.dll, libpq.dll, ssleay32.dll) (which I've downloaded from the Customer Portal-> Package: PostgreSQL_Client_Libraries_for_Windows_101_130031.exe) into the \bin-Directory of my ArcGIS Server 10.2 installation. I'm even not sure, if I need this....
  • I've copied the necessary st_geometry file (stored in the Installation folder of your ArcGIS installation (D:\Programs\ArcGIS 10.2\Desktop10.2\DatabaseSupport) into the \lib-Directory of my PostgreSQL 9.2.2 installation.
  • I've registered the database and the folder via the ArcGIS Server manager in the data store tab. I'm not sure if this right or necessary!?
  • The connection via pgAdmin works. I can connect to the database using pgAdmin. Here I have three tables: http://imgur.com/pkY0LmV
  • The connection via "ArcCatalog-> Add Database Connection" is finally working. I can connect to the database. As a database I can only select "postgis20" as a database?! Any idea, why it's like that?! http://imgur.com/rQYpjbc I think that it has to be postgres, hasn't it?

From now on I don't know how, what are the next steps. Can anybody confirm that the above mentioned steps are right?

And it would be awesome if someone of you could give me some tips, how I have to work on or what are the next steps. Do I have to "Enable Geodatabase"? Do I have to create an Enterprise Geodatabase with the ArcToolbox Tool? I've spent too many hours without having success :(

My goal: Enabling WFS and Feature Access.

Thanks a lot

Edit Started from scratch regarding database. See each second comment of this post and answer. Btw:...first time for me using stackexchange.com.

  • 1
    postgis20 has the right roles and privileges based on the logged in user. Then publish your service resources.arcgis.com/en/help/main/10.2/index.html#//… – Mapperz Aug 19 '13 at 14:07
  • you will need to connect with the same user (in the publish mxd) that you used to register the database. Other than that I don't see where the problem could be. double clicking on the error in will bring up help for resolving. – Brad Nesom Aug 19 '13 at 14:51
  • Hello, Thanks for your feedback. To make it easier figuring out, what's going wrong, I've started from scratch (in regard to databases). Would be awesome if someone of you could have a look here: forums.arcgis.com/threads/… Problem: I can't add the connection to the database, because I haven't got the chance to select one database. The existing database "postgres" (look screenshot of pg Admin; it exsits!) is not selectable via the "Add Database connection" assistant. – schlomm Aug 20 '13 at 1:03
  • comments should be kept to comments. additional questions either spun out to their own question or added to original question. – Brad Nesom Aug 20 '13 at 17:17
  • have you made the database available? postgres defaults to not shared. Off the top of my head it seems like it is in pg_hba.conf (I don't have a postgres db anymore) – Brad Nesom Aug 20 '13 at 17:20
2

It sounds like your next step is to simply create a service with the desired capabilities enabled.
Open arcmap, add the data you want.
Symbolize and make it look like you want. You might take a look at these web seminars and the esri video channel
when you publish your service you make sure to check the capabilities section and enable the desired output.
After selecting the desired capabilities go to each section and configure the options.
WFS config

Then you will need to consume those services in your application/viewer of choice.

As per your follow on question about postgres (should probably be by itself).
Look in the \install dir\postgres\ver#\data\ folder for the pg_hba.conf
Edit the host section with your machine and connection type. There is some help in that file and more online.

  • Thanks so much for your feedback. Unfortunately I'm still not able to publish WFS or Feature Access. I use my map document with 3 polygon shapefiles and 4 point shapefiles. Then I want to publish this as a service, select my server, activate "WFS" and "Feature Access" in the Capabilities-Tab. Then I "Analyze" the Service, where I get an Error: imgur.com/gBqcF44 Here I go through "Show data store regsitration page", where I register my existing database and the folder. Validating both gives me an okay. Then "analyzing" again - > Same error :( – schlomm Aug 19 '13 at 14:48
  • By the way: WFS works now...I think my problem was, thinking, that WFS doesn't work as well, that I've always tried to publish WFS and Feature Access at the same time. So I've thought that there is also a problem with WFS...Anyway...I've started from scratch using and setting up PostgreSQL: gis.stackexchange.com/questions/69073/… Woudl be absolutely awesome to get some help. – schlomm Aug 20 '13 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.