3

I upgraded from QGIS 1.7.0 to 1.8.0, including updating GRASS to version 6.4.3. Since then, GRASS isn't any longer listed in the Fetch Python plugins. I uninstalled and re-installed the whole package without any results. Any tips how to reactivate GRASS in my system (OSX 10.6.8)? Thanks

EDIT: Apparently Sextante has to be activated to be able to load the GRASS plugin. However, the "importlib" Python module is lacking to activate Sextante. Any suggestions on how to install this module?

1

The final solution was going back to GRASS 6.4.2. This restores the GRASS plugin. Sextante was only a partial solution, as not all the GRASS modules are integrated in Sextante and Sextante also cannot open GRASS layers into QGIS. Unfortunately GRASS 6.4.2. for Mac isn't available on Kyngchaos.com, but I could retrieve it on a backup.

0

did you check the framework? If not, go the the following page and install the belonging packages: http://www.kyngchaos.com/software/qgis

In respect to the "importlib" Python module I tried to install it separately without success. I simply wait for QGIS 2.0.

nice regards, Jörn

  • Thanks Jörn for your reply. I - again - reinstalled everything (cfr. sites.google.com/site/eospansite/qgis-installation) for Mac, however, still no Sextante or GRASS working. – user21193 Aug 20 '13 at 12:08
  • Finally Sextante is running and the GRASS tools are available again. Wes Kent's post on tinyurl.com/k4damob inspired me to find the solution. To install importlib, I rebooted my MacBook as an admin user, started Terminal and used the command "sudo easy_install importlib". Python then makes a connection to a module database, downloads the importlib module and installs it. – user21193 Aug 20 '13 at 13:41
0

Mmh, its well described on the sites you sent but I just want to ask you, which GDAL you installed? QGIS 1.8 needs GDAL 1.9 not 1.10. Whats about the other frameworks? I run the same system like you (10.6.8) and have to problems. I know its sounds stupid but did you activate the plugin via the QGIS Plugin Manager?

Did you set the path in the Menue/Raster/Gdal Tool settings: Here one has to put the following in 'Path to the GDAL executables' and 'Path to the GDAL python modules': /Library/Frameworks/GDAL.framework/Programs:/usr/bin

regards, Jörn

  • The problem is that QGIS 1.8 needs GDAL 1.9, but GRASS 6.4.3 needs GDAL 1.10. So now I've both versions running, hope this won't create problems. – user21193 Aug 20 '13 at 13:51
  • On activating the GRASS plugin in the Plugin Manager: the GRASS plugin isn't longer available in QGIS 1.8.2 (or I couldn't find it). – user21193 Aug 20 '13 at 13:54
0

Problem Solved. Wes Kent's post http://tinyurl.com/k4damob inspired me to find the solution. To install importlib, I rebooted my MacBook as an admin user, started Terminal and used the command "sudo easy_install importlib". Python then makes a connection to a module database, downloads the importlib module and installs it. For the missing psycopg2 I followed the instructions on http://www.kyngchaos.com/software/python. Next Sextante can be installed at the Fetch Python Plugins menu. After installing, enable Sextante in the Plugin Manager and Sextante Toolbox in the new Analysis menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.